TM: No substantial speed increase

RESOLVED DUPLICATE of bug 489146

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 489146
9 years ago
9 years ago

People

(Reporter: Dannii, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.8) Gecko/2009033100 Ubuntu/9.04 (jaunty) Firefox/3.0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b4pre) Gecko/20090401 Ubuntu/9.04 (jaunty) Shiretoko/3.5b4pre

By profiling with Firebug enabling JIT seems to make no difference to the performance of this page.

Reproducible: Always

Steps to Reproduce:
Enter the three commands 'y', 'n', 'n'.


Expected Results:  
Some, if minimal, speed increase.

About 15% of the time is taken by eval() (in ge_run) which I wouldn't expect to be helped by the JIT.

The rest is just a lot of function calls, however most functions are quite short and straightforward. For example, ge_func_return: http://code.google.com/p/parchment/source/browse/trunk/gnusto-engine.js#2943
(Reporter)

Comment 1

9 years ago
Created attachment 373628 [details]
Logs from Firebug

Updated

9 years ago
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general

Comment 2

9 years ago
JIT is not yet enabled for x86_64. See bug 489146.

I'm not completely sure, but having the Firebug profiler active may disable TM (Firebug activates the JavaScript debugger service which does not play well with TM IIRC).

It could be interesting if you try again with a 32bit build and maybe with Firebug off if it doesn't make a difference. That's always interesting to hear about TM performance improvements.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 489146
You need to log in before you can comment on or make changes to this bug.