JPEG decoder does not use fastpath when CMS mode is tagged-only

RESOLVED FIXED

Status

()

RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: ilpo.ruotsalainen, Assigned: ilpo.ruotsalainen)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
User-Agent:       Opera/9.63 (X11; Linux i686; U; en) Presto/2.1.1
Build Identifier: 

When CMS is enabled in tagged-only mode, the JPEG decoder does not use the direct YCC->ARGB path even for images where it could be used (ie. images without an ICC profile).

Reproducible: Always
(Assignee)

Comment 1

10 years ago
Created attachment 373630 [details] [diff] [review]
Fix for the issue

Average execution time for my JPEG loading benchmark case goes down from 414.67sec to 399.10sec on a 1GHz SnapDragon (ARMv7) with this patch.
Comment on attachment 373630 [details] [diff] [review]
Fix for the issue

Nice catch.

Do you need someone to check this in for you?
Attachment #373630 - Flags: review+
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

10 years ago
(In reply to comment #2)
> Do you need someone to check this in for you?

Yes please.
Marking as checkin-needed.
Keywords: checkin-needed
Assignee: nobody → ilpo.ruotsalainen
And removing checkin-needed; I'll just check this in myself when my commit access request goes through.

Do we need to get another review of this, since the r+ is a year old?  JOEDREW, what do you think?
Keywords: checkin-needed
If the patch still applies and/or only has some fuzz, check it in!
Attachment #373630 - Flags: approval2.0?

Updated

9 years ago
Attachment #373630 - Flags: approval2.0? → approval2.0+
http://hg.mozilla.org/mozilla-central/rev/3c5313a9c437
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.