do_timeout should take a function as its argument, not a string

VERIFIED DUPLICATE of bug 525819

Status

--
minor
VERIFIED DUPLICATE of bug 525819
10 years ago
9 years ago

People

(Reporter: Waldo, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
I don't know why do_timeout takes a string and evals it rather than just calling a callback function, but as far as I can tell there isn't a good reason to do so.  We should change the API to be sane, perhaps by accepting either a function or a string as the execute-later-argument to start.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 525819
V.Duplicate
Status: RESOLVED → VERIFIED
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.