[MSFT-7594] Firefox does not associate with .url files when set as the default browser

RESOLVED WONTFIX

Status

()

Firefox
Installer
RESOLVED WONTFIX
9 years ago
7 years ago

People

(Reporter: abillings, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Description of the Problem: Internet shortcuts created with Internet Explorer do not change icon to Firefox icon

Detailed Steps to Reproduce the Problem:  

1.	Install Windows 7
2.	Launch Internet Explorer
3.	Create a shortcut in a folder by dragging from the address bar
4.	Install Firefox from www.firefox.com
5.	Launch Firefox
6.	Make Firefox the default browser
7.	Actual Result  Shortcut still shows Internet Explorer icon

This happens in 3.5 b4pre: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b4pre) Gecko/20090420 Shiretoko/3.5b4pre



Tester/Developer Notes: 

The list of Firefox associations in Control Panel\Programs\Default Programs\Set Default Programs\Set Program Associations, does not include .URL so .URL files do not get associated with Firefox.

If the user manually associates .URL with Firefox, the proper icon is shown.  Firefox needs to include .URL as an extension that they support if they want this.

Firefox does not take over URLs on Windows 7, Vista RTM, or Vista SP1.  Firefox is just not set up to take over url files.
(Reporter)

Updated

9 years ago
Version: 3.0 Branch → 3.1 Branch
(Reporter)

Comment 1

9 years ago
This applies to 1.9.0 (Firefox 3) and 1.9.2 (Firefox 3.6) builds as well.
Version: 3.1 Branch → Trunk

Updated

9 years ago
Summary: [MSFT-7594] Internet shortcuts created with Internet Explorer do not change icon to Firefox icon → [MSFT-7594] Firefox does not associate with .url files when set as the default browser
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Assignee: robert.bugzilla → nobody
Component: General → Installer
QA Contact: general → installer
I've installed Opera, Chrome, and Safari none of which have the ability to take over .url since they don't have the requisite registry settings and none of which have .url listed in ontrol Panel\Programs\Default Programs\Set Default Programs\Set Program Associations.

.url files use ieframe.dll to hand off the url contained in the url file to the appropriate handler so for example http is handed off to the http handler, mailto is handed off to the mailto handler, etc. and so it is associated with the appropriate icon for that handler.

This is also works for me on Firefox. I suspect that this was tested using a non admin account which will be fixed by Bug 404541.
This is a mass change. Every comment has "assigned-to-new" in it.

I didn't look through the bugs, so I'm sorry if I change a bug which shouldn't be changed. But I guess these bugs are just bugs that were once assigned and people forgot to change the Status back when unassigning.
Status: ASSIGNED → NEW
We aren't going to create our own broker for handing off .url shortcuts to the appropriate application... hell, these are protocol shortcuts that were implemented by the OS shell so the shell should handle them. Resolving -> wontfix
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.