[SeaMonkey, Windows] (TUnit) xpcshell-tests (test_bug457886 or) test_charset_conversion.js crashes(?) / times out often now

RESOLVED FIXED in seamonkey2.0b1

Status

defect
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: sgautherie, Assigned: kairo)

Tracking

(Blocks 1 bug, {intermittent-failure})

Trunk
seamonkey2.0b1
x86
Windows Server 2003
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [clobbering fixed this!] [cc-orange])

Reporter

Description

10 years ago
Green log is like
{
TEST-PASS | d:\builds\slave\comm-central-win32-unittest\build\objdir\mozilla\_tests\xpcshell\test_intl_uconv\unit\test_bug457886.js | all tests passed
TEST-PASS | d:\builds\slave\comm-central-win32-unittest\build\objdir\mozilla\_tests\xpcshell\test_intl_uconv\unit\test_charset_conversion.js | all tests passed
TEST-PASS | d:\builds\slave\comm-central-win32-unittest\build\objdir\mozilla\_tests\xpcshell\test_intl_uconv\unit\test_decode_8859-1.js | all tests passed
}

Red log is like
{
TEST-PASS | d:\builds\slave\comm-central-win32-unittest\build\objdir\mozilla\_tests\xpcshell\test_intl_uconv\unit\test_bug457886.js | all tests passed

command timed out: 300 seconds without output, killing pid 10464
SIGKILL failed to kill process
}

test_charset_conversion.js was added by bug 368142,
test_bug457886 by 457886.
Flags: wanted1.9.1?
Reporter

Comment 1

10 years ago
It looks like:

This (random) failure was first reported by
{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1240109424.1240112337.31582.gz
WINNT 5.2 comm-central unit test on 2009/04/18 19:50:24
}

Before that we had another (random) "related" failure which was first reported by
{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1240057436.1240059388.11517.gz
WINNT 5.2 comm-central unit test on 2009/04/18 05:23:56

make[4]: Entering directory `/d/builds/slave/comm-central-win32-unittest/build/objdir/mozilla/intl/uconv/tests'
/d/mozilla-build/python25/python \
          /d/builds/slave/comm-central-win32-unittest/build/mozilla/testing/xpcshell/runxpcshelltests.py \
          ../../../dist/bin/xpcshell \
          ../../../_tests/xpcshell/test_intl_uconv/unit

command timed out: 300 seconds without output, killing pid 8708
SIGKILL failed to kill process
}
Blocks: 438871
Depends on: 368142
Summary: [SeaMonkey, Windows] (TUnit) xpcshell-tests test_bug457886 or test_charset_conversion.js crashes(?) / times out often now → [SeaMonkey, Windows] (TUnit) xpcshell-tests (test_bug457886 or) test_charset_conversion.js crashes(?) / times out often now
Whiteboard: [orange]
Reporter

Comment 2

10 years ago
(In reply to comment #1)

> http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1240109424.1240112337.31582.gz
> WINNT 5.2 comm-central unit test on 2009/04/18 19:50:24

New error report timeframe is:
http://hg.mozilla.org/releases/mozilla-1.9.1/pushloghtml?startdate=2009-04-18+05%3A18%3A24&enddate=2009-04-18+19%3A47%3A25
which is a big TraceMonkey landing.

> http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1240057436.1240059388.11517.gz
> WINNT 5.2 comm-central unit test on 2009/04/18 05:23:56

Possible regression timeframes could be:
http://hg.mozilla.org/releases/mozilla-1.9.1/pushloghtml?startdate=2009-04-17+23&enddate=2009-04-18+05%3A18%3A26
http://hg.mozilla.org/comm-central/pushloghtml?startdate=2009-04-17+23&enddate=2009-04-18+05%3A12%3A28
but can't be sure of the start, as the failure is random.
(I would check bug 479624 first, but just random guessing.)
Reporter

Comment 3

10 years ago
Can someone reproduce?

(Fwiw, afair, I've never seen this with my SM/1.9.2 build...)
Keywords: qawanted
Reporter

Comment 4

10 years ago
Simon, would you rs that I "bypass" this test for SeaMonkey+Windows only, ftb?
Assignee

Comment 5

10 years ago
Actually, just as you said "which was a big TraceMonkey landing", it dawned to me that we sometimes had problems with dep test builds after TraceMonkey landings in the past. Let me clobber the test machine to see if this helps.
(In reply to comment #4)
> Simon, would you rs that I "bypass" this test for SeaMonkey+Windows only, ftb?

Sure, if clobbering doesn't help.
Assignee

Comment 7

10 years ago
I forgot to report back, we haven't had xpcshell-tests showing the problem since I clobbered that machine, so maybe this problem is fixed (unfortunately, we have other failures in mochitests).
Reporter

Comment 8

10 years ago
I confirm comment 5 clobber fixed this bug :-)

***

But it happened again today:
{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1240495923.1240498771.21467.gz
WINNT 5.2 comm-central unit test on 2009/04/23 07:12:03
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1240503123.1240505824.6817.gz
WINNT 5.2 comm-central unit test on 2009/04/23 09:12:03
}

KaiRo, can you clobber again?
Assignee: nobody → kairo
Status: NEW → ASSIGNED
Flags: wanted1.9.1?
Keywords: qawanted, regression
Product: Core → SeaMonkey
QA Contact: general → general
Target Milestone: --- → seamonkey2.0b1
Version: 1.9.1 Branch → Trunk
Reporter

Updated

10 years ago
Whiteboard: [orange] → [cloberring fixes this!] [orange]
Assignee

Comment 9

10 years ago
This bug is open but targeted for seamonkey2.0b1, which has already been released. Please set the target milestone to an appropriate value, "---" if it has no specific target.
Assignee

Comment 10

10 years ago
Serge, that said, is this stil a problem?
Assignee: kairo → nobody
Target Milestone: seamonkey2.0b1 → ---
Reporter

Comment 11

10 years ago
I don't think this is still happening.
Anyway, we know how to fix it now :-)
Assignee: nobody → kairo
Blocks: SmTestFail
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Whiteboard: [cloberring fixes this!] [orange] → [clobbering fixed this!] [orange]
Target Milestone: --- → seamonkey2.0b1
Whiteboard: [clobbering fixed this!] [orange] → [clobbering fixed this!]

Updated

7 years ago
Whiteboard: [clobbering fixed this!] → [clobbering fixed this!] [cc-orange]
You need to log in before you can comment on or make changes to this bug.