Creation of task with due date and custom alarm of type before/after "the event ends" results in no visibility of task (i.e., it does not show) in calendar views.

RESOLVED DUPLICATE of bug 349529

Status

Calendar
Calendar Views
--
major
RESOLVED DUPLICATE of bug 349529
9 years ago
9 years ago

People

(Reporter: gogoboomer, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.21) Gecko/20090403 SeaMonkey/1.1.16
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18pre) Gecko/20080917 Sunbird/0.9

When creating a task with a due date (start date bypassed), and then setting a custom alarm for some time period before or after "the event ends", the resultant task does not appear in any of the calendar views (day, week, multiweek, or month). It is visible in the Tasks pane in lower left corner, however.

Reproducible: Always

Steps to Reproduce:
1. File | New Task.
2. Checkmark and set Due Date.
3. Select Reminder | Custom....
4. Set reminder interval for some period (e.g. 14 days) before or after "the event ends".
5. Click "Save and Close".
Actual Results:  
Task does not appear in any calendar views. It does appear in Tasks pane.

Expected Results:  
Show task in any/all calendar views.

Also verified in the following build (nightly, 20090421): Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090421 Calendar/1.0pre

This appears to be related to Bug 479578 and Bug 349529. The same resolution/fix/application response to Bug 479578 seems reasonable here. Set the Start date implicitly (greyed) to Due Date upon return from Custom alarm dialog.

As users, if we're not entering anything in the Start date fields, then we really aren't concerned with that attribute -- our concern is the due date, and our ability to set alarms with respect to the due date, and of course, our ability to see the task on all calendar views.

Hope this helps...
If you set an alarm related to the due date only the due date is required. There is no need to enforce a start date. (Due to Bug 486186 you might see some issues in 1.0pre test builds after restarting the application.)

The "display task with only due date in views" is handled in Bug 339955 -> Bug 349529 as you already mentioned.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 349529
You need to log in before you can comment on or make changes to this bug.