"Open Link in New Tab" should come first

VERIFIED DUPLICATE of bug 322736

Status

()

Firefox
Menus
--
enhancement
VERIFIED DUPLICATE of bug 322736
9 years ago
9 years ago

People

(Reporter: r610n21, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-IE][parity-Chrome][parity-opera])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.8) Gecko/2009033100 Ubuntu/9.04 (jaunty) Firefox/3.0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.8) Gecko/2009033100 Ubuntu/9.04 (jaunty) Firefox/3.0.8

Right-clicking a link the menu shows up with "Open Link in New Window" and then "Open Link in New Tab". I think "Open Link in New Tab" should be above since the user generally wants to open a new tab, not a new window.
I noticed it in Google Chrome 2 and I find it very handy.


Reproducible: Always

Updated

9 years ago
Severity: trivial → enhancement
Version: unspecified → Trunk

Comment 1

9 years ago
I like the idea since tabs browsing is more common now.  IE 7 and Opera 9.63 both have the tab option before the window option.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Does the UX team agree?
Keywords: uiwanted
yeah, makes sense.  We probably want to go back and look at all of our context menus to make sure things are right.
Could someone iterate all context menus where this change would apply?
Keywords: uiwanted
I swear this is a dupe, but I can't find it.

We'll certainly break users by changing this behaviour, whether we care is the question. :)

Comment 6

9 years ago
The opposite change is called for in bug 490507.

Comment 7

9 years ago
Didn't we have an extended conversation about this about six years ago? I have searched Bugzilla but can't find it. I believe it occurred pretty soon after tabs were introduced. 

It is logical that the "window" menu options are listed above the "tab" menu options. Windows contain tabs. Tabs do not contain windows. 

It would be illogical and unnatural to list "tab" options before "window" options. 

For the sake of logic, the File menu should be left the same. For the same of UI consistency, and the serendipity of the last menu item being easier to mouse to than the second-to-the-last menu item, the "tabs" item in the History menu should be moved below the "window" item. See the bug report I mentioned above: bug 490507. 

I recommend WONTFIX here.

Updated

9 years ago
Whiteboard: [parity-IE]

Updated

9 years ago
Whiteboard: [parity-IE] → [parity-IE][parity-Chrome]

Updated

9 years ago
Whiteboard: [parity-IE][parity-Chrome] → [parity-IE][parity-Chrome][parity-opera]
Six years ago would have been the Mozilla Suite.  Or Firebird 0.7.  It was a long time ago, when we defaulted to windows over tabs, and no other major browser supported tabs.  Conclusions then should not impair decisions now.

Your apparent logic implies that there should be a hierarchy among same-level UI based on conceptual purity over frequency of use.  We should focus on frequency of use and optimize for the majority case, which is definitely tabs at this point.
Bug 149297 ftw :)

Context menus are:

Browser, Bookmarks, History (may be the same as bookmarks). That should be it, afaik. Bookmarks and history include sidebar, library, menu, toolbar, etc. but they all get there context menus from the same place.

Comment 10

9 years ago
I have posted further arguments as to why this should be WONTFIX at bug 490507 comment 4.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 322736

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.