Crash when switching theme (Classic->Modern)

VERIFIED FIXED

Status

P3
major
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: hyatt)

Tracking

({crash, regression})

Trunk
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Every time I tried to switch the theme back to Modern, I crash right after 
clicking ok in the warning dialog. When I restart the application, the theme 
still Classic. I was able to switch themes last week (Thursday or Friday)
(Reporter)

Updated

18 years ago
Keywords: dogfood, regression

Comment 1

18 years ago
Adding myself to the CC... this is hurting me as well. I always crash somewhere 
in XBL though, so I'm reassigning to hyatt.

Here is one stack trace:

#0  0x416adad1 in nsXBLStreamListener::OnStopRequest (this=0x8d85378, 
    aChannel=0x8cead10, aCtxt=0x0, aStatus=2152398850, aStatusArg=0x401228fc)
    at ../../../dist/include/nsCOMPtr.h:489
#1  0x40c99545 in nsResChannel::EndRequest (this=0x8cead10, 
    aStatus=2152398850, aStatusArg=0x401228fc) at nsResChannel.cpp:708
#2  0x40c994e0 in nsResChannel::OnStopRequest (this=0x8cead10, 
    transportChannel=0x8d85500, context=0x0, aStatus=2152398850, 
    aStatusArg=0x401228fc) at nsResChannel.cpp:701
#3  0x40c8b24b in nsFileChannel::OnStopRequest (this=0x8d85500, 
    transportChannel=0x8cee358, context=0x0, aStatus=2152398850, 
    aStatusArg=0x401228fc) at nsFileChannel.cpp:632

Assignee: hangas → hyatt
(Reporter)

Comment 2

18 years ago
David Hyatt's last check in in nsXBLservice.cpp fixed the problem
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 3

18 years ago
I'm still seeing something real similar (WinNT, with the latest version of 
nsXBLService.cpp).

If I go to Bugzilla and enter a bug # (40792, in my case), I get a crash with 
the same call stack as posted here.  Note that I first get the "form submission" 
warning dialog, so it might have something to do with that.  I'll be trying this 
same scenario with the official bits from today (as soon as they show up).

BTW, I also ran into the same crash in the course of testing my fix for a bug.  
That fix involves some hairy timing dependent code and multiple dialogs closing 
simultaneously, so maybe it's me in that case, but seems like too much of a 
coincidence.
(Assignee)

Comment 4

18 years ago
Bill, if you reproduce this again, save the stack for me.  I can't reproduce 
using your test...

Comment 5

18 years ago
Adding crash keyword for fix and/or verification escalation
Keywords: crash

Comment 6

18 years ago
Updated QA contact
QA Contact: paw → pmac

Comment 7

18 years ago
This is fixed in all platforms (Build: 2000082508M18).
Status: RESOLVED → VERIFIED

Updated

14 years ago
OS: All
Hardware: Macintosh → All
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.