please QA the 3.5 First Run page

VERIFIED FIXED in 3.5

Status

defect
VERIFIED FIXED
11 years ago
7 years ago

People

(Reporter: jslater, Assigned: stephend)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

()

This is one of the big ones needed for l10n, so if you're prioritizing which of the 3.5-related pages you QA first, this should move to the front of the line.

Thanks!
One thing I just noticed:
The blue background kind of cuts off on the left & right sides of the content (unlike the current live content, in which the blue background extends infinitely). Can we fix that to match the live site?
[1] Can we make "Visit Firefox Support" and "Explore Add-ons" align?
[2] Do we want to make the nurse and the add-ons logo clickable? (Not sure.)
[3] Please change the link to SUMO to just "http://support.mozilla.com" (this is the more future-proof link, I'm told).

Maybe more later...
Krupa: some notes about in-product pages: they only need to be tested in the latest, soon-to-be shipping version of Firefox.

The page validates and all links work.
Assignee: nobody → stephen.donner
[4] Video no longer works for me in Shiretoko.
(In reply to comment #4)
> [4] Video no longer works for me in Shiretoko.
What behaviour are you seeing? Thanks.
(In reply to comment #5)
> (In reply to comment #4)
> > [4] Video no longer works for me in Shiretoko.
> What behaviour are you seeing? Thanks.

Nevermind, it actually works; you have to wait for quite a while before the overlayed "Play" icon shows up, though.
(In reply to comment #6)
> Nevermind, it actually works; you have to wait for quite a while before the
> overlayed "Play" icon shows up, though.

I think this is an encoding issue (not streamable). We're having some video pros look at it.
Steven / John / Pascal: once issues 1-4 are addressed along with John's issue mentioned in comment 1 (not necessarily all fixed), this page looks ready to be handed off to localizers.
(In reply to comment #8)
> Steven / John / Pascal: once issues 1-4 are addressed along with John's issue
> mentioned in comment 1 (not necessarily all fixed), this page looks ready to be
> handed off to localizers.
Thanks Stephen!

Steven G, do you have an estimate for when we can get these fixes made? The localizers are (understandably) eager to get started on this one.
(In reply to comment #2)
> [1] Can we make "Visit Firefox Support" and "Explore Add-ons" align?
Fixed in r25101.

> [2] Do we want to make the nurse and the add-ons logo clickable? (Not sure.)
As background images, this would be a bit of a hack in implementation, so I've left this off for now.

> [3] Please change the link to SUMO to just "http://support.mozilla.com" (this
> is the more future-proof link, I'm told).
Fixed in r25101.

It'll take a while to get the properly encoded video in place, but this shouldn't hold up localization.
(In reply to comment #1)
> One thing I just noticed:
> The blue background kind of cuts off on the left & right sides of the content
> (unlike the current live content, in which the blue background extends
> infinitely). Can we fix that to match the live site?

Fixed.
OK -- we can deal with the video separately.

I'm signing off on this so l10n can being their work ASAP.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
reopening:

1/ alt="Welcome to Firefox 3" in image should be 3.5
2/<div class="mozilla-video-control" style="width: 200px; height: 110px;">
why these online styles aren't in the external style sheet?
3/ is there a need to add width and height attributes to <video> and <img> tags? AFAIK, they are optional and for the video we are already defining them by css
4/<video id="video" src="http://labs.silverorange.com/files/mozilla-videos/BigBuckBunnyShort.ogg" -> even though the video is not ready, the url should be the final mozilla one so as to avoid reediting all locales' files just to update the url
5/ nitpick, <a href="/<?=$lang?>/firefox/central/">Happy browsing</a>!</p> I would include the exclamation mark into the link
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
All the comments in #13 seem good to me...Steven, please make the fixes when you can. (although I'll say that I see 3.5 for the logo already)
(In reply to comment #13)
Issues 1, 2, 3, & 5 are fixed in r25150. As for the place-holder URL, I wanted to keep that in there to test the video playing in the mean time.

I've replaced the video URL with what could be a "real" url when we have the actual video - though this means the video is broken in the meantime (I suppose we could put a placeholder video up there for now) - r25151.
One small final fix...please change "Our Support page..." copy to read "Our Support site..."

We should be all set after that.
(In reply to comment #16)
> One small final fix...please change "Our Support page..." copy to read "Our
> Support site..."

Done in r25180.
Safe to mark this as fixed?
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
(In reply to comment #18)
> Safe to mark this as fixed?

I think so -- thanks for doing so; we've already started localizing this, so it seems we're good to go.
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.