Browser chrome stops <svg width="100%"> resizing below some width

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
10 years ago
11 months ago

People

(Reporter: jwatt, Unassigned)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
For some reason 100% wide SVG always gets a computed width of 410px or greater.
Flags: blocking1.9.1?
(Reporter)

Comment 1

10 years ago
Created attachment 373947 [details]
testcase -resize the window from wide to narrow and at some point the rect stops resizing

I'm not sure how to write a testcase that will fail for an arbitrary content width < 410px.
(Reporter)

Updated

10 years ago
Assignee: nobody → jwatt
(Reporter)

Comment 2

10 years ago
As roc points out, this is because the browser chrome won't resize narrower than a certain width (the exact value of which is dependent on the toolbars you have showing and their contents). Once the chrome stops resizing smaller, so does the XUL <browser>, and thus our percentage width in the SVG is being resolved against a much larger width that it appears.
Flags: blocking1.9.1?
Summary: 100% wide SVG always gets a computed width of 410px or greater → Browser chrome stops <svg width="100%"> resizing below some width
(Reporter)

Updated

10 years ago
Attachment #373947 - Attachment description: testcase - try resizing the window to be less than 410px wide → testcase -resize the window from wide to narrow and at some point the rect stops resizing
(Reporter)

Comment 3

10 years ago
For me it's at the point when the navigation bar stops resizing smaller that the SVG in the content area stops resizing as it should.
(Reporter)

Comment 4

10 years ago
Yeah, so the chrome tree above the SVG doc looks something like this:

<window id="main-window">
  <toolbox id="navigator-toolbox">
    <toolbar id="toolbal-menubar">
    <toolbar id="nav-bar">
    <toolbar id="PersonalToolbar">
  </toolbox>
  <hbox id="browser">
    <vbox id="appcontent">
      <tabbrowser id="content">
        <tabbox>
          <tabpannels>
            <notificationbox>
              <browser>
                #document
                  <svg:svg>
                    ...
                  </svg:svg
              </browser>
            </notificationbox>
          </tabpannels>
        </tabbox>
      </tabbrowser>
    </vbox>
  </hbox>
</window>

If anything inside #navigator-toolbox won't resize below a certain width, then it prevents the <window> from resizing below that width, and thus everything under #browser is also not resized below that width.

Not really sure how we can fix this.
Doesn't this affect html too? I think this is likely a duplicate of something more general.
(Reporter)

Updated

11 months ago
Assignee: jwatt → nobody
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.