test_largemenu.xul fails when the screen size is an odd number

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: roc, Assigned: roc)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Posted patch fixSplinter Review
Hopefully the attached patch will make the problem clear.

I'm not 100% sure this is the right fix though, so requesting review. The test does pass with the patch on an odd-height screen.
Attachment #373992 - Flags: review?(enndeakin)
Attachment #373992 - Flags: review?(enndeakin) → review+
Comment on attachment 373992 [details] [diff] [review]
fix

Seems ok. The problem is caused because in the call to openPopupAtScreen, y may be a non-integer. Add a comment to that effect.
http://hg.mozilla.org/mozilla-central/rev/70e967153bbc
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.