No "more" button shown for multiple mail addresses although there should be one

RESOLVED FIXED in Thunderbird 3.0b3

Status

Thunderbird
Message Reader UI
--
major
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: BenB, Assigned: BenB)

Tracking

Trunk
Thunderbird 3.0b3
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

9 years ago
If the first recipient email addresses are long, and the message pane/viewer is not very wide, the "more" on the "to:" etc. lines are pushed into the area of some other widget (the invisible S/MIME or Junk/Scam icon? the "hide details" button?) and not visible. The typical "overflow: hidden" behavior: Once you widen the window, the "more" gradually appears, first partially cut offm then fully.

If the first email address(es) on "cc" line are shorter than on the "to" line, the "more" buttons for cc and to appear at different times / positions. This indicates that the "more" button is not in an absolute place, but on the same box as the email addresses, and thus pushed out due to long addresses.

This is a followup of bug 443893, which describes a similar, but different bug in TB 2.x.

You can however use the testcase of bug 443893 comment 12 - it also triggers this bug, even easier (one message with long recipient email addresses is sufficient).
Flags: blocking-thunderbird3?
(Assignee)

Comment 1

9 years ago
Created attachment 374085 [details] [diff] [review]
Fix, v1
[Checkin: Comment 7]

Fix was luckily fairly obvious.
Attachment #374085 - Flags: review?
(Assignee)

Comment 2

9 years ago
Created attachment 374086 [details]
Screenshot after Fix v1
(Assignee)

Updated

9 years ago
Attachment #374085 - Flags: review? → review?(dmose)
Thanks for the fix; sorry for the delay reviewing.  It's near the top of my review list.
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Whiteboard: [needs review dmose]
Target Milestone: --- → Thunderbird 3.0b3
Comment on attachment 374085 [details] [diff] [review]
Fix, v1
[Checkin: Comment 7]

Looks good; thanks for the fix!  r=dmose
Attachment #374085 - Flags: review?(dmose) → review+

Updated

9 years ago
Whiteboard: [needs review dmose] → [needs checkin]

Comment 5

9 years ago
Reviewed a month ago... check-in ready?
Keywords: checkin-needed
(Assignee)

Comment 6

9 years ago
Yup, will do. Sorry.
Comment on attachment 374085 [details] [diff] [review]
Fix, v1
[Checkin: Comment 7]


http://hg.mozilla.org/comm-central/rev/c1377f62bfbd
Attachment #374085 - Attachment description: Fix, v1 → Fix, v1 [Checkin: Comment 7]
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [needs checkin]

Updated

9 years ago
Duplicate of this bug: 498224
You need to log in before you can comment on or make changes to this bug.