Firefox 3.1b3 building failure when compiling with gcc-4.4.0

RESOLVED DUPLICATE of bug 478843

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 478843
9 years ago
9 years ago

People

(Reporter: Andrey Karlov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b3) Gecko/20090313 Firefox/3.1b3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b3) Gecko/20090313 Firefox/3.1b3

Configuration:
./configure --prefix=/opt/firefox_3.1b3 --silent --enable-application=browser --enable-official-branding --disable-accessibility --disable-jsd --enable-optimize=-O2 --disable-logging

And i got:
/mmedia/downloads/sources/mozilla-1.9.1/dist/bin/xpidl -m typelib -w -I. -I../../dist/idl -e _xpidlgen/nsINativeAppSupport.xpt -d .deps/nsINativeAppSupport.pp nsINativeAppSupport.idl
/usr/bin/python ./make-platformini.py --buildid=20090422204205  ../../config/milestone.txt > platform.ini
/mmedia/downloads/sources/mozilla-1.9.1/dist/bin/xpt_link _xpidlgen/xulapp.xpt _xpidlgen/nsINativeAppSupport.xpt 
make[4]: *** [nsAppRunner.o] Error 1
make[4]: Leaving directory `/mmedia/downloads/sources/mozilla-1.9.1/toolkit/xre'
make[3]: *** [libs] Error 2
make[3]: Leaving directory `/mmedia/downloads/sources/mozilla-1.9.1/toolkit'
make[2]: *** [libs_tier_toolkit] Error 2
make[2]: Leaving directory `/mmedia/downloads/sources/mozilla-1.9.1'
make[1]: *** [tier_toolkit] Error 2
make[1]: Leaving directory `/mmedia/downloads/sources/mozilla-1.9.1'
make: *** [default] Error 2


Reproducible: Always

Steps to Reproduce:
Configuration with other options (such as CXXFLAGS, CFLAGS, etc), e.g.:
./configure --prefix=/mmedia/firefox_3.1b3 --silent --enable-application=browser --enable-official-branding --disable-accessibility --enable-optimize=-O3

Output:
....
....
c++ -o nsUpdateDriver.o -c -I../../dist/include/system_wrappers -include ../../config/gcc_hidden.h -DIMPL_XREAPI -DMOZ_UPDATER -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_COM_OBSOLETE -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DZLIB_INTERNAL -DOSTYPE=\"Linux2.6.29\" -DOSARCH=Linux -DOS_TARGET=\"Linux\" -DTARGET_XPCOM_ABI=\"x86_64-gcc3\" -DTARGET_OS_ABI=\"Linux_x86_64-gcc3\"  -DTOOLKIT_EM_VERSION=\"1.9.1b3\" -DWRAP_SYSTEM_INCLUDES -I../../widget/src/xremoteclient -I. -I./../profile/src -I../../config  -I. -I. -I../../dist/include/appcomps -I../../dist/include/toolkitcomps -I../../dist/include/appshell -I../../dist/include/chrome -I../../dist/include/content -I../../dist/include/docshell -I../../dist/include/dom -I../../dist/include/embed_base -I../../dist/include/embedcomponents -I../../dist/include/extensions -I../../dist/include/gfx -I../../dist/include/intl -I../../dist/include/js -I../../dist/include/necko -I../../dist/include/pref -I../../dist/include/profile -I../../dist/include/string -I../../dist/include/uriloader -I../../dist/include/widget -I../../dist/include/windowwatcher -I../../dist/include/xpcom -I../../dist/include/xpconnect -I../../dist/include/xpinstall -I../../dist/include   -I../../dist/include/xulapp -I/mmedia/downloads/sources/mozilla-1.9.1/dist/include/nspr     -I/mmedia/downloads/sources/mozilla-1.9.1/dist/sdk/include    -fPIC   -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-long-long -pedantic -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O3 -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -I/usr/include/pixman-1 -I/usr/include/gtk-unix-print-2.0   -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2     -DMOZILLA_CLIENT -include ../../mozilla-config.h -Wp,-MD,.deps/nsUpdateDriver.pp nsUpdateDriver.cpp
make[4]: *** [nsAppRunner.o] Error 1
make[4]: *** Ожидание завершения заданий...
make[4]: Leaving directory `/mmedia/downloads/sources/mozilla-1.9.1/toolkit/xre'
make[3]: *** [libs] Error 2
make[3]: Leaving directory `/mmedia/downloads/sources/mozilla-1.9.1/toolkit'
make[2]: *** [libs_tier_toolkit] Error 2
make[2]: Leaving directory `/mmedia/downloads/sources/mozilla-1.9.1'
make[1]: *** [tier_toolkit] Error 2
make[1]: Leaving directory `/mmedia/downloads/sources/mozilla-1.9.1'
make: *** [default] Error 2
Actual Results:  
none

Expected Results:  
successful build

Linux 2.6.29.1, glibc-2.7-18, Debian GNU/Linux 5.1, GNOME 2.22.3

Comment 1

9 years ago
This bug report has everything except the important bit: the actual build error reported by GCC. Since you're doing a parallel build, the error will be a bit farther up in the build log (or you can skip the parallel build).
GCC 4.4.0 builds fails for me too (trunk builds of Seamonkey and Minefield).
However, a dirty fix would be to disable crashreporter.
So, in .mozconfig: ac_add_options --disable-crashreporter then build will be fine again.

Comment 3

9 years ago
Please reopen this bug with the correct details when they are available.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE

Comment 4

9 years ago
Bug is about the stray elif statement in nsAppRunner.cpp I will attach the patch for thunderbird-3.0b2 should be easy enough to backport to all other branches.
Status: RESOLVED → VERIFIED

Comment 5

9 years ago
Created attachment 384257 [details] [diff] [review]
thunderbird gcc-4.4 compile fix

Patch is easy to understand, any questions ask. I will try and get the cvs trees checked out and make proper cvs diff for current HEAD.

Comment 6

9 years ago
Already fixed, see bug 478843 for details.
Status: VERIFIED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 478843
You need to log in before you can comment on or make changes to this bug.