All characters on web page display as Unicode "unknown character" squares

RESOLVED DUPLICATE of bug 489445

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 489445
9 years ago
9 years ago

People

(Reporter: gerv, Unassigned)

Tracking

1.9.1 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

1. Visit http://blog.seanmartell.com/2009/04/21/css3-flexible-ui-avoid-recutting-ui-graphics-for-mobile/
2. Page briefly appears with correct characters
2. Page changes to look like screenshot (to be uploaded)

The View | Character Encoding list says "UTF-8", although View | Character Encoding | Autodetect was set to Chinese for some reason. This could be a red herring. However, setting it to Universal doesn't fix anything. This doesn't occur if you save the page to disk and load it from there. 

My guess: something is happening to trigger charset autodetection when the page has loaded, and it's getting it wrong. 

Gerv
Created attachment 374104 [details]
Screenshot of problem

Note the correctly-rendered text in the search textbox.

I'm using Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3.

Gerv
Very odd! Since the codepoints in the boxes are actually the correct codepoints for the text in the page, it looks more like a font issue than an encoding issue, but I have no notion why we aren't finding a font for vanilla ASCII-range characters.
Might be a dupe of bug 489445.
Assignee: smontagu → nobody
Component: Internationalization → GFX: Thebes
QA Contact: i18n → thebes
Simon: seems pretty likely to be a dupe of bug 489445. That page does use downloadable fonts, and they are rare enough that it would explain why I've only seen this a couple of times. I've checked, and the fonts do seem to be present on the web server...

Who should be looking at this problem, do you think? Is there anything else I can do to help debug?

Gerv
Yes, looks the same as bug 489445.

Gervase, please let me know if you have a pango version < 1.24.
("pkg-config --modversion pango" if you have dev packages installed.)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 489445
You need to log in before you can comment on or make changes to this bug.