Closed Bug 489628 Opened 11 years ago Closed 11 years ago

avoid closure for attrChanged in tabbrowser.addTab

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 3.6a1

People

(Reporter: dao, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Keywords: memory-leak, verified1.9.1)

Attachments

(2 files, 1 obsolete file)

spin-off from bug 489622:

>  * the tab elements are leaked for multiple reasons:
> 
>    + one is that they're sometimes entrained by the closure attrChanged in the
> tabbrowser binding's addTab method.
Blocks: 489622
Keywords: mlk
Attached patch wip patch (obsolete) — Splinter Review
I think this should fix it, but I haven't tested it yet..
That patch would likely also fix bug 358362.
Blocks: 358362
Assignee: nobody → dao
Attachment #374106 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #374315 - Flags: review?(gavin.sharp)
Attachment #374315 - Flags: review?(gavin.sharp) → review+
http://hg.mozilla.org/mozilla-central/rev/d092e63f5f84
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.6a1
same as for trunk, except for not removing the resetOwner method
Attachment #374438 - Flags: approval1.9.1?
Comment on attachment 374438 [details] [diff] [review]
patch for 1.9.1 branch
[Checked in: Comment 7]

a191=beltzner
Attachment #374438 - Flags: approval1.9.1? → approval1.9.1+
This checkin was in a range identified with a Ts Shutdown regression on Windows:

Regression: Ts Shutdown increase 27.64% on WINNT 5.1 Firefox3.5
   Previous results:
       357.263 from build 20090506145316 of revision 486b76052a94 at 2009-05-06 14:53:00
   New results:
       456.0 from build 20090506155401 of revision 7aa4483585bd at 2009-05-06 15:54:00
http://graphs-new.mozilla.org/graph.html#tests=[{"machine":32,"test":36,"branch":3},{"machine":33,"test":36,"branch":3},{"machine":34,"test":36,"branch":3},{"machine":35,"test":36,"branch":3},{"machine":48,"test":36,"branch":3}]&sel=1241564040,1241736840
No longer blocks: 499429
Blocks: 402147
No test failures since the checkin on 1.9.2 and 1.9.1. Looks like that another caused the Ts Shutdown regression given by comment 8. Marking as verified fixed.
Status: RESOLVED → VERIFIED
Attachment #374315 - Attachment description: patch → patch [Checked in: Comment 4]
Attachment #374438 - Attachment description: patch for 1.9.1 branch → patch for 1.9.1 branch [Checked in: Comment 7]
You need to log in before you can comment on or make changes to this bug.