Frequent "Alert: COPY failed" alerts in IMAP account - data loss?



MailNews Core
Networking: IMAP
9 years ago
9 years ago


(Reporter: Nelson Bolyard (seldom reads bugmail), Unassigned)


(Depends on: 1 bug)

1.9.0 Branch
Windows XP

Firefox Tracking Flags

(Not tracked)


(Whiteboard: [needs protocol log])

Running a not-very-recent trunk build...

Today, every few minutes, I get a pair of Alert dialogs. 
The first says:   

> Alert
> COPY failed

The second says:

> Alert
> The current command did not succeed.  The mail server responded: [ALERT] COPY failed.

I suspect that these are coming from the mail filters' attempts to copy 
messages to other folders.  

These alerts really trouble me because:
1) They do not tell me any useful information such as:
- the name of the server on which the copy operation failed
- the name of the destination folder to which the copy was being attempted
- the name of the source    folder from which the copy was being attempted
- anything about the mail message itself, subject, From, date ... nothing
- what has happened to the message as a result of the failure.  Lost? 
  left in some source folder?  

If these failures are indeed happening as a result of message filters attempting to move messages to other folders, then there should be a message
in the filter log saying 
- a filter action failure occurred
- what filter was trying to execute, 
- what message it was trying to copy
- what happened to the message (e.g. left in Inbox, or something)
I assume IMAP, because of next.
> The current command did not succeed. The mail server responded: [ALERT] COPY failed.

Nelson Bolyard, can you get IMAP log?
> Getting NSPR log      : See Bug 402793 Comment #1
> IMAP command/response :
If you can test on MS Win, you can get log with timestamp, and you can do ad-hoc check of Tb's IMAP level flow while Tb is running, by viewing console of DebugView.
> Adding timestmap to log by DebugView : See Bug 402793 Comment #6


9 years ago
Depends on: 489873

Comment 2

9 years ago
Nelson, can you attach log with timestamp using the new, simplified ",timestamp"?

wada, with regard to bug 489873 - the message not being helpful - is this another case of us just regurgitating the imap response?
Whiteboard: [needs protocol log]
Wayne,  In late April, I went through a period of several days during
which those alerts were frequent.  But that stopped as mysteriously as 
it began, and I've not seen one in several weeks now.  Next time I see 
one, I will try to get a log file.

Comment 4

9 years ago
OK, let's be optimistic close for now, reopen if it reappears.
but bug 489873 should remain open - wada can you comment there?
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.