Missing symbols for xul.dll for Firefox 3.0.9

RESOLVED FIXED

Status

--
blocker
RESOLVED FIXED
10 years ago
2 years ago

People

(Reporter: yuhongbao_386, Assigned: reed)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9 (.NET CLR 3.5.30729)

Symbols for xul.dll from Firefox 3.0.9 are missing from the symbol server.

Reproducible: Always

Steps to Reproduce:
1. Install Firefox 3.0.9.
2. Run SYMCHK against xul.dll from it.
Actual Results:  
SYMSRV:  C:\downloads\symbols\xul.pdb\6CCB4A89D6914C85A6203DF6629036A8c\xul.pdb
not found
SYMSRV:  http://symbols.mozilla.org/firefox/xul.pdb/6CCB4A89D6914C85A6203DF66290
36A8c/xul.pdb not found
DBGHELP: xul - no symbols loaded
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
I think this goes to RelEng? Maybe?
Component: General → Release Engineering
Product: Firefox → mozilla.org
QA Contact: general → release
Version: 3.0 Branch → other
File appears to be present:
surf:/mnt/netapp/breakpad/symbols_ffx $ ls -l xul.pdb/6CCB4A89D6914C85A6203DF6629036A8c/
total 105896
-rw-r--r--  1 ffxbld users 67489792 Apr  8 22:49 xul.pdb
-rw-r--r--  1 ffxbld users 40719447 Apr  8 22:49 xul.sym
Similar size to 3.0.7 and 8.

Not served correctly though
$ curl -I http://symbols.mozilla.org/firefox/xul.pdb/6CCB4A89D6914C85A6203DF6629036A8c/xul.pdb
HTTP/1.1 404 Not Found
Date: Thu, 23 Apr 2009 05:16:42 GMT
Server: Apache/2.2.3 (Red Hat)
Content-Type: text/html; charset=iso-8859-1
Via: 1.1 bc3
Connection: Keep-Alive

Perhaps a more general problem with http on the symbol server ?
Assignee: nobody → server-ops
Status: UNCONFIRMED → NEW
Component: Release Engineering → Server Operations
Ever confirmed: true
OS: Windows Vista → All
QA Contact: release → mrz
(Assignee)

Comment 3

10 years ago
[root@pm-web01 symbols]# service httpd reload
Reloading httpd: not reloading due to configuration syntax error
                                                           [FAILED]

Debugging now...
Assignee: server-ops → reed
Severity: major → blocker
Hardware: x86 → All
I ran through the manifest firefox-3.0.9-WINNT-2009040821-symbols.txt and tried to HEAD each file. These ones were 404's
 npmozax.pdb/90A67828EC0A400F941BC9A95A3D784Ba/npmozax.sym
 npmozax.pdb/90A67828EC0A400F941BC9A95A3D784Ba/npmozax.pdb
 xul.pdb/6CCB4A89D6914C85A6203DF6629036A8c/xul.sym
 xul.pdb/6CCB4A89D6914C85A6203DF6629036A8c/xul.pdb
 ia2marshal.pdb/542440AD94D846D98A1024FD5FC665841b/ia2marshal.sym
 ia2marshal.pdb/542440AD94D846D98A1024FD5FC665841b/ia2marshal.pdb
and the rest 200.

Those are the only URLs with a UID ending in a lowercase letter, so probably something with the rewrite rule.
(Assignee)

Comment 5

10 years ago
Multiple different syntax errors both on MPT static cluster and AMS/NL clusters. I've reverted the change that caused the issue for now, and everything seems to be back to working order.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

10 years ago
I can confirm that this issue is fixed. SYMCHK now correctly downloads xul.pdb
Product: mozilla.org → mozilla.org Graveyard

Comment 7

2 years ago
http://symbols.mozilla.org/firefox/xul.pdb/04477C20855F439CBD58C311613D2AA92/xul.pdb


C:\Program Files\Mozilla Firefox>"C:\Program Files\Debugging Tools for Windows (
x86)\symchk.exe"    "C:\Program Files\Mozilla Firefox\xul.dll"  /s SRV*C:\Symbol
s\*http://symbols.mozilla.org/firefox /oe /v
[SYMCHK] Searching for symbols to C:\Program Files\Mozilla Firefox\xul.dll in pa
th SRV*C:\Symbols\*http://symbols.mozilla.org/firefox
DBGHELP: Symbol Search Path: SRV*C:\Symbols\*http://symbols.mozilla.org/firefox
[SYMCHK] Using search path "SRV*C:\Symbols\*http://symbols.mozilla.org/firefox"
DBGHELP: No header for C:\Program Files\Mozilla Firefox\xul.dll.  Searching for
image on disk
DBGHELP: C:\Program Files\Mozilla Firefox\xul.dll - OK
DBGHELP: C:\Program Files\Debugging Tools for Windows (x86)\sym\xul.pdb\04477C20
855F439CBD58C311613D2AA92\xul.pdb - file not found
DBGHELP: xul - no symbols loaded
[SYMCHK] MODULE64 Info ----------------------
[SYMCHK] Struct size: 1672 bytes
[SYMCHK] Base: 0x10000000
[SYMCHK] Image size: 11878400 bytes
[SYMCHK] Date: 0x4d852c15
[SYMCHK] Checksum: 0x00b44192
[SYMCHK] NumSyms: 0
[SYMCHK] SymType: SymNone
[SYMCHK] ModName: xul
[SYMCHK] ImageName: C:\Program Files\Mozilla Firefox\xul.dll
[SYMCHK] LoadedImage: C:\Program Files\Mozilla Firefox\xul.dll
[SYMCHK] PDB: ""
[SYMCHK] CV: RSDS
[SYMCHK] CV DWORD: 0x53445352
[SYMCHK] CV Data:  e:\builds\moz2_slave\rel-192-w32-bld\build\obj-firefox\toolki
t\library\xul.pdb
[SYMCHK] PDB Sig:  0
[SYMCHK] PDB7 Sig: {00000000-0000-0000-0000-000000000000}
[SYMCHK] Age: 0
[SYMCHK] PDB Matched:  TRUE
[SYMCHK] DBG Matched:  TRUE
[SYMCHK] Line nubmers: FALSE
[SYMCHK] Global syms:  FALSE
[SYMCHK] Type Info:    FALSE
[SYMCHK] ------------------------------------
SymbolCheckVersion  0x00000002
Result              0x00010001
DbgFilename         xul.dbg
DbgTimeDateStamp    0x00000000
DbgSizeOfImage      0x00000000
DbgChecksum         0x00000000
PdbFilename         e:\builds\moz2_slave\rel-192-w32-bld\build\obj-firefox\toolk
it\library\xul.pdb
PdbSignature        {04477C20-855F-439C-BD58-C311613D2AA9}
PdbDbiAge           0x00000002
[SYMCHK] [ 0x00000000 - 0x00010001 ] Checked "C:\Program Files\Mozilla Firefox\x
ul.dll"
SYMCHK: xul.dll              FAILED  - xul.pdb mismatched or not found

SYMCHK: FAILED files = 1
SYMCHK: PASSED + IGNORED files = 0


this pdb don't download also, how can i slove the problem?
thank you very much
(Reporter)

Comment 8

2 years ago
Symbols are now compressed, so the right URL is http://symbols.mozilla.org/firefox/xul.pdb/04477C20855F439CBD58C311613D2AA92/xul.pd_ .

Check the directory C:\Symbols\xul.pdb\04477C20855F439CBD58C311613D2AA92\.

Comment 9

2 years ago
ok,i find the file in the  path "C:\symbols\xul.pdb\04477C20855F439CBD58C311613D2AA92\xul.pd_"  but this  file is   incomplete(only 1.23MB) which auto download by windbg,but the firefox.pdb is correct.

why the xul.pdb did not download by windbg? the networt?
(Reporter)

Comment 10

2 years ago
Yes, it is probably the network. Delete the file and it should download again.
You need to log in before you can comment on or make changes to this bug.