HTML message text is too small

RESOLVED INVALID

Status

Thunderbird
Message Reader UI
--
major
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: Gili, Unassigned)

Tracking

({qawanted, testcase})

Trunk
x86
Windows Vista
qawanted, testcase
Bug Flags:
blocking-thunderbird3 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9 (.NET CLR 3.5.30729)
Build Identifier: 

HTML messages on high-dpi environments display way too small (looks like 4pt font!). Plain/text messages display just fine. I consider this a major usability problem for Thunderbird because about 50% of my mail is unreadable. I keep on having to enlarge the font using CTRL+ but then plain/text messages become too big. There doesn't seem to be a way to get both to display using a decent-sized font. I tried all the font-related configuration options and none helped (yes, I tried configuring the minimum font size).

The only thing that I have found which works is to set:

* {
font-size: 18pt !important
}

in userContent.css. Now HTML messages are decent sized and plain-text are just a bit too big (but it's bearable).

Reproducible: Always
(Reporter)

Comment 1

9 years ago
Created attachment 374203 [details]
Screenshot of the problem
Does this happen in Thunderbird 3.0 betas also?
(Reporter)

Comment 3

9 years ago
Yes. Thunderbird 3.0 beta 2 has the same bug.

Comment 4

9 years ago
Can you attach a sample message? (Save as .eml)
HTML mails can specify whatever font size they like to use. Maybe the sender is specifying a very small size.
Version: unspecified → Trunk
(Reporter)

Comment 5

9 years ago
Created attachment 374697 [details]
sample HTML message
(Reporter)

Comment 6

9 years ago
Message attached. Magnus, please take a look.
Keywords: testcase

Comment 7

8 years ago
Looks pretty normal to me when i open it. Maybe you have your font-settings set oddly somehow. 

Gili, if you still see it, try a build from
ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/ or
http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
(Reporter)

Comment 8

8 years ago
Hi Magnus,

I tried Thunderbird 3.0b4pre and I still see this problem. I will attach a screenshot for you.
(Reporter)

Comment 9

8 years ago
Created attachment 398422 [details]
Screenshot from 3.0b4pre
This is a pretty in-your-face failure mode.  If this happens to all of our Vista users with large monitors, that's pretty painful, and might well want to block.  Adding qawanted in the hopes of getting a second set of eyes on it so it can move from UNCONFIRMED to NEW state and actually be considered for blocking.

rebron, do we have any idea what percentage of our users are on Vista these days?
Flags: blocking-thunderbird3?
Keywords: qawanted
From memory, over 90% total on Windows.  Of that I would say close to 2/3rds on Vista.
As far as we know, this doesn't happen w/ a lot of people, because it requires fairly non-standard system font choices.  Denying blocking on that assumption, and if that assumption is wrong, please renominate.
Flags: blocking-thunderbird3? → blocking-thunderbird3-
Gili: can you describe your system font / theme choices in some detail so that folks can try to reproduce this?
(Reporter)

Comment 14

8 years ago
"As far as we know, this doesn't happen w/ a lot of people, because it requires
fairly non-standard system font choices."

I'd love to know where you got this from. I am running the standard Vista theme with the background changed to a solid blue color. I fail to see anything non-standard here. The fonts are set to 96 DPI which is the default setting.

Why hasn't a single person confirmed that they can reproduce this issue? Why is the status of this issue "unconfirmed"? Why am I made to jump through hoops trying one nightly build after another instead of the developers taking concrete steps to isolate reproducing the problem so they can debug it on their own end?

I'd be glad to provide you with any information you need to that end, but again I believe I am using the default theme.
Gili: The screenshot doesn't seem to match the font choices that others are seeing, that's what prompted the comment.

Several of us haven't been able to repro this, hence we suspect something about your setup is different, and causing the problem.  We don't know what that is as yet, but that's why the bug is marked UNCONFIRMED.

Sid, Wayne, can either of you repro this?
(Reporter)

Comment 16

8 years ago
Got it!!!

David, you are a genius ;) Your first sentence triggered an idea in my mind. I started going through my prefs.js file changing the Thunderbird font settings one by one until I found the culprit. It turns out that adding:

user_pref("font.name.serif.x-western", "Angsana New");

will trigger this problem. I've had this problem for *years* so I have no idea how this setting ended up in my config in the first place.

Question: why does the font choice matter if I specified the minimum font size is 16? Isn't the font size unit in pixels? Is there anything we can do in Thunderbird to avoid this kind of issue from occurring in the future?
My guess: Some HTML emails end up changing the font size using various CSS rules, some proportional (80%, 'smaller'), and I wouldn't be surprised if some fonts scale badly down.

I'm glad that resolved in.  Can we close this bug?
(Reporter)

Comment 18

8 years ago
David,

No, something else is going wrong. Take a look at the "sample HTML message" attachment I posted a while ago. It uses no such CSS tricks and yet it rendered using tiny font. I think other users will run into this problem in the future unless we modify Thunderbird to avoid it in the future. For starters we you to reproduce the problem on your end. Then we need to figure out why this font choice causes "sample HTML message" to render tiny. Then we need to figure out if there is anything we can do about it (to either render bigger or to warn the user of the problem).
I opened that email, and it looks fine, as it's not really an HTML message anyway.  I suspect you have more font configuration weirdnesses.  Can you try to create a new thunderbird profile and open the message with that profile?
(Reporter)

Comment 20

8 years ago
David,

1) Create a new Thunderbird account
2) Add

user_pref("font.name.serif.x-western", "Angsana New");

to the new account prefs.js

3) Open the "sample HTML message" attachment under the new profile
4) Notice the font is tiny

In other words, applying this single line is enough to screw up any Thunderbird configuration.
There are lots of ways in which users can shoot themselves in the foot, unfortunately.

I don't have that font, so I can't test it.  Can you test w/ other fonts?  If it's only an issue for a small set of fonts, I doubt it'll be realistically fixable.

Comment 22

8 years ago
Seems entirely due to the Angsana font and offhand I'd say it's a poor choice of font. At 16 (the default) it's quite small, as you say.  At 22 it becomes readable. Different fonts do not all display at same height for the same font size. 

Contrast that with Times Roman at 16. I use 120dpi on my vista dell d531 with 1440x900. tested also on my dell desktop same settings (and clean profile). sample message looks same in plain text.  my thunderbird display options are 
times roman 16pt
advanced: western: proportional=Serif 16, monospace=courier 13
which I think are default settings

=> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 23

8 years ago
1) Why is 16pt in one font so much smaller than another? Aren't they supposed to have the same height?

2) Isn't it possible for Thunderbird to calculate the pixel size of each font and warn if it is too small?
You need to log in before you can comment on or make changes to this bug.