Mail preview contents overflows the container and covers the statusbar

RESOLVED DUPLICATE of bug 499543

Status

Thunderbird
Message Reader UI
RESOLVED DUPLICATE of bug 499543
9 years ago
9 years ago

People

(Reporter: u344248, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090422 Shredder/3.0b3pre ID:20090422031642

When viewing mail in main window preview area, sometimes the contents overflow the container and cover the statusbar. It happens when all mail details are visible or an additional info toolbar (eg. that remote images where blocked) is being displayed AND the preview area is very small.

Reproducible: Always

Steps to Reproduce:
1. select an e-mail in main window, so the preview shows up
2. click the "show details" button
3. make the preview area smaller, so that only the mail headers are visible

Actual Results:  
The contents of the preview area overflow and cover the statusbar contents

Expected Results:  
A scrollbar should appear or the overflow should be hidden or the preview area should collapse
(Reporter)

Comment 1

9 years ago
Created attachment 374253 [details]
Screenshot that presents the bug

This screenshot presents the bug
(Reporter)

Comment 2

9 years ago
Created attachment 374254 [details]
2-nd screenshot of the bug
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
looks like a bug, not sure if that's some kind of toolkit issue w/ windows.  Does this happen in TB2 as well?
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> looks like a bug, not sure if that's some kind of toolkit issue w/ windows. 
> Does this happen in TB2 as well?

yes, the same happens in TB2 (screenshot: http://img15.imageshack.us/img15/4189/th4.png )
(Reporter)

Comment 5

9 years ago
Found a small solution for this issue.

#messagepanebox {
	overflow: hidden !important;
}

I added the above snippet into userChrome.css and it solved the problem in TB 3 builds.

In TB 2 it solved the problem partially. The text content hides itself now, but the background of the header view covers the statusbar ( http://img232.imageshack.us/img232/5241/th5.png )
Interesting; thanks for continuing to investigate.  If you feel like playing around some more, installing DOM inspector might be helpful.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499543
You need to log in before you can comment on or make changes to this bug.