If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Gmail]Broken Russian encoding in subjects and attached files names

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
--
major
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Dmitry Romanov, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.9) Gecko/2009040820 Firefox/3.0.9
Build Identifier: version 2.0.0.21 (20090302)

Mac OS X leopard 10.5.6

have no problem with Russian layout, but in Sunbird (https://bugzilla.mozilla.org/show_bug.cgi?id=489788) 0.9 and Thunderbird 2.0.0.21 I had big problem which blocks work

I have English localization in Mac OS
Auto encoding in Thunderbird works fine for the mail content, but doesn't work for Russian signs in e-mail Subject and in Attached files name. Instead of Russian symbols I have "???????" as you can see on the attached picture.

I can create new e-mail and type with Russian layout with no problems. The issue with ??? instead of Russian appears only on the main Thunderbird window and on the "Write new e-mail" window in Subject and TO fields (Russian content inside mail body - ok).



Reproducible: Always

Steps to Reproduce:
1. Start Thunderbird
2. Connect to my mail server using IMAP
3. Receive e-mails
4. Notice that I have ??? instead of Russian signs in the subject
Actual Results:  
??? instead of signs
have ??? when typing new e-mail subject or mail receipt name

Expected Results:  
Russian signs should be encoded correctly
(Reporter)

Comment 1

9 years ago
Created attachment 374263 [details]
Thunderbird window
Whiteboard: dupme
(Reporter)

Comment 2

9 years ago
Last night I installed Thunderbird 3.0b2 and it fixed this issue.
It seems the rootcase is bug in Gecko in Thunderbird 2.0, because Sunbird 0.9 still has ??? instead of Russian signs.
Resolving WFM then. Thanks for testing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

9 years ago
If you need additional info or testing feel free to contact me

Comment 5

9 years ago
Dimitry probably problem also because Subject not encoded properly. So TB3 just land something which have workaround for this.

Comment 6

9 years ago
This is Gmail specific only. Not sure how this can be solved because Subject field are not properly encoded. I've still seen this on latest trunk.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090428 Shredder/3.0b3pre
Status: RESOLVED → UNCONFIRMED
Component: General → Folder and Message Lists
OS: Mac OS X → Windows XP
QA Contact: general → folders-message-lists
Resolution: WORKSFORME → ---
Version: unspecified → Trunk
Summary: Broken Russian encoding in subjects and attached files names → [Gmail]Broken Russian encoding in subjects and attached files names
Whiteboard: dupme

Comment 7

9 years ago
I believe this is may somehow related to language you have selected in gmail web interface. This type of problem exist during launch of IMAP in gmail.
Depends on: 402793
To Dmitry Romanov(bug opener):
Can you attach mail data which produces your problem?
- Save the mail to ".eml" file
- Attach the file to this bug via "Add an attachment" link(text/plain is preferable).
Blocks: 402793
No longer depends on: 402793
(Reporter)

Comment 9

9 years ago
Created attachment 376281 [details]
requested sample
(Reporter)

Comment 10

9 years ago
as I told have no problem with Thunderbird 3.0
issues appears only in 2.0 version
Dmitry Romanov, what is your setting of mail folder?  
> Folder Properties
>   General Informations
>     Default Character Encoding: ???
>       [?] Apply deafult to all messages in the folder(individual message
>           character encoding settngs and suto-detection will be ignored)

Comment 12

9 years ago
(In reply to comment #10)
> as I told have no problem with Thunderbird 3.0
> issues appears only in 2.0 version

->WFM then
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.