Submitting form with many, many fields hangs for a long time before completing

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Terrence G. Inglebrook, Unassigned)

Tracking

3.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)

When clicking on the SUBMIT button of a form that contains a couple thousand INPUT fields, the entire browser "hangs" for a long time while uploading the data. This makes for an ugly user experience, and ought to be better threaded.

Specifically, at MyDomain.com I manage several Internet domains, including hundreds of Email accounts/aliases. In this particular case, I currently have 646 items in the FORM, and each row contains 4 INPUT fields (2584 fields), plus a number of additional fields outside the table, for a total of 2875 fields.

(for your examination, a copy of the exact form is stored in www.tgi.org/p/firefox_submit_bug.zip)

I saw Bug #345250, but that's not the same.

Reproducible: Always

Steps to Reproduce:
1. Start with a FORM that has multiple hundreds of INPUT fields containing smallish amounts of data.
2. Click the SUBMIT button for the FORM.
Actual Results:  
The browser "hangs" for the entire duration of the data upload to complete the SUBMIT operation. When the upload completes, the browser resumes normal behavior.

Expected Results:  
This ought to be politely threaded. The original Mozilla/Netscape browser did not experience this symptom. This is new behavior since I switched from Netscape to Firefox.

The affected tab/window ought to still be responsive (and not cause Windows Vista to pop up the "this program is not receiving input" dialog box, asking if you want to kill it), and the user ought to be able to continue to use the other tabs/windows of the browser.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0 Branch
This is a mass search for Firefox General bugs filed against version 3.0 that are UNCO and have not been changed for 200 days.

Reporter, please update to Firefox 3.6.10 or alter. Firefox 3.0 is no longer supported and is no longer receiving updates. After you update, please create a fresh profile, http://support.mozilla.com/kb/managing+profiles, and test to see if your bug still exists. If you still the bug, then please post a comment with the version you tested against, and the problem. If the issue is no longer there, please set the RESOLUTION to  RESOLVED, WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Comment 2

8 years ago
Was fixed probably in Firefox 3.3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.