Crashes when correctly closed.

RESOLVED INCOMPLETE

Status

()

--
critical
RESOLVED INCOMPLETE
10 years ago
9 years ago

People

(Reporter: grzollar, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9

I have been getting crash message boxes when I boot up and start Firefox again.
This is beginning to happen regularly.
I close Firefox sometimes with active tabs.
I get crash message when I open browser again.

Reproducible: Sometimes

Steps to Reproduce:
1.Use browser
2.Have (or not) open tabs to any sites
3.Close Firefox, turn off computer, boot later, open Firefox, message appears.
Actual Results:  
Sometime crash message appears

Expected Results:  
No crash

N/A

Comment 1

10 years ago
Crashes are always critical severity, even on exit. Not only could the crash be in the middle of saving something important, but it's always possible you can hit it some other way. Crashes are always bad.

Post crash ID:
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
Severity: minor → critical
Version: unspecified → 3.0 Branch

Comment 2

9 years ago
No reply. Closing as INCOMPLETE. If you can still get this in a current version of Firefox 3.5.2 the please reopen this and post your crash ID or stacktrace.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

9 years ago
Read about add-on's crashing, hopefully Mozilla is following Safari and allowing the add-on to crash without Firefox suffering.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 4

9 years ago
(In reply to comment #3)
> Read about add-on's crashing, hopefully Mozilla is following Safari and
> allowing the add-on to crash without Firefox suffering.

Yes, that's in development but is not related to this.


Please provide the necessary information and this can gladly be looked into. If you don't reply with anything there's simply nothing for us to go on here.

Please read and follow the instructions linked to in comment 1. Update to the current version of Firefox 3.5.2 or at least 3.0.13 and if you still get this then post a crash ID or other stacktrace as instructed.
(Reporter)

Comment 5

9 years ago
There is nothing I do.
At times, now often, when I close Firefox with several tabs open one of several things occur.  
I will find it still running if I check my processes after being told it crashed.
When I think it has closed it will not reopen and the message that it is still running appears.  
I don't know if these are reproducible errors.
If you suspect the crash is related to an extension, it would be nice if you could figure out which extension correlates with it, by disabling them selectively.  And as others said, a stack trace could help.

But rest assured that we are trying to create a restricted extension API so extensions can't get themselves into so much trouble: https://jetpack.mozillalabs.com/.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 7

9 years ago
(In reply to comment #6)
> If you suspect the crash is related to an extension, it would be nice if you
> could figure out which extension correlates with it, by disabling them
> selectively.  And as others said, a stack trace could help.
> 
> But rest assured that we are trying to create a restricted extension API so
> extensions can't get themselves into so much trouble:
> https://jetpack.mozillalabs.com/.

I looked up stack traces C#, VB, Javascipt, and others.  I would have no idea which to use or where to write the code and I have no compiler for any language or the necessary skill to execute it.  Good idea for someone who could use it.
I have reamed my system with a variety of cleaners and direct invasion of the registry, after removing a lot of junk I have only seen the issue once.
Not a 100% cure but much better. Whatever was getting crossed is 90+% gone.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 8

9 years ago
> (In reply to comment #7)
> I looked up stack traces C#, VB, Javascipt, and others.  I would have no idea
> which to use or where to write the code and I have no compiler for any language
> or the necessary skill to execute it.  Good idea for someone who could use it.

Gerald, you're unnecessarily confusing yourself here. 17 minutes after you posted this report I gave you a link to a page that tells you how to get a crash report ID. It seems that in the 5 months since that you still haven't read that page. If there is something on that page that you can't understand, then please ask. (I have recently simplified it even more than previously)

PLEASE READ THE INSTRUCTIONS I ALREADY GAVE YOU:
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report

There is no code to write or any skill needed; you just need to follow the instructions. You let it submit a crash report when it asks you to and then you get the ID of that report from about:crashes to give to us. If the crash reporter is working as implied by you getting a "crash message", then that's it. If not, there's Windbg, but you haven't replied to the first method yet. Please at least acknowledge the help I'm trying to give you.

> I have reamed my system with a variety of cleaners and direct invasion of the
> registry, after removing a lot of junk I have only seen the issue once.
> Not a 100% cure but much better. Whatever was getting crossed is 90+% gone.

If you can't reproduce this at all anymore and don't have a crash ID for this, then feel free to close this report as WORKSFORME (not FIXED). If you can still get this, a support article for Jesse's suggestion in comment 6 is here, which you can do in addition to getting the crash ID as suggested above:
http://support.mozilla.com/en-US/kb/Troubleshooting+extensions+and+themes
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.