All users were logged out of Bugzilla on October 13th, 2018

Scroll bars (scrolling = yes) not showing all scroll bars

VERIFIED DUPLICATE of bug 44306

Status

()

P3
major
VERIFIED DUPLICATE of bug 44306
18 years ago
2 months ago

People

(Reporter: bugzillaabuse, Assigned: pollmann)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.73C-CCK-MCD AOLNSCP (Macintosh; I; PPC)
BuildID:    2000-08-07-12

Frame scrolling = yes is acting exactly like scrolling = auto and not showing the 
horizontal scroll bars.

Reproducible: Always
Steps to Reproduce:
http://slip/projects/marvin/html/frame_scrolling_yes_cols.html
http://slip/projects/marvin/html/frame_scrolling_yes_rows.html

both demonstrate the problem.

Actual Results:  No horizontal scroll bars.

Expected Results:  Horizontal bars should be there, but grayed out.

scrolling = yes is a very popular feature...thus the designation Major.
lorca@netscape.com - in general, please attach testcases to bugs :-) There are 
quite a few external people working on Mozilla, you know...

Gerv
(Reporter)

Comment 2

18 years ago
My apologies, and the test cases:)-

Columns Test Case:
<FRAMESET COLS="33%, 33%, 33%" >
        <FRAME SRC="frame_name_target.html" scrolling=yes>
        <FRAME SRC="default.html" scrolling=yes>
        <FRAME SRC="frame_name_target.html" scrolling=yes>
</FRAMESET>
Rows Test Case:
<FRAMESET ROWS="33%, 33%, 33%">
        <FRAME SRC="frame_name_target.html" scrolling=yes>
        <FRAME SRC="default.html" scrolling=yes>
        <FRAME SRC="frame_name_target.html" scrolling=yes>
</FRAMESET>
(Reporter)

Comment 3

18 years ago
My apologies, and the test cases:)-



Columns Test Case:

<HEAD>

<HTML>

<TITLE>HTML Functional -- FRAME - SCROLLING=YES COLS</TITLE> 

        <FRAMESET COLS="33%, 33%, 33%" >

        <FRAME SRC="frame_name_target.html" scrolling=yes>

        <FRAME SRC="default.html" scrolling=yes>

        <FRAME SRC="frame_name_target.html" scrolling=yes>

        </FRAMESET>

</HEAD>

</HTML>



Rows Test Case:

<HEAD>

<HTML>

<TITLE>HTML Functional -- FRAME - SCROLLING=YES ROWS</TITLE> 

        <FRAMESET ROWS="33%, 33%, 33%">

        <FRAME SRC="frame_name_target.html" scrolling=yes>

        <FRAME SRC="default.html" scrolling=yes>

        <FRAME SRC="frame_name_target.html" scrolling=yes>

        </FRAMESET>

</HEAD>

</HTML>

Comment 4

18 years ago
Scrolling does work for both horizontal and vertical scroll bars. In this test 

case, the frames only scroll vertical since the data flows inside the frame's 

width specfied. If you resize the main window horizonallty, the horizontal scroll 

bars will become active on all three frames. Also, loading our HTML matrix in 

either of these frames will also cause the horizontal scrollbar activate. The 

page contains a table which is wider that the frame's width.

(Reporter)

Comment 5

18 years ago
Actually, from what I understand (I could be wrong here) the 
scrolling = yes
command should not just create scroll bars in the necessary direction, but in *
both* directions.  If you want the bar to appear in the direction that is 
necessary only, the command should be
scrolling = auto.
If I'm off base here, let me know.  4.X and IE 5.0 (both Mac) demonstrate the 
behavior that supports my theory.
(Reporter)

Updated

18 years ago
Summary: Frame Scrolling not functional (rows and cols) → Scroll bars (scrolling = yes) not showing all scroll bars

Comment 6

18 years ago
Confirming bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

18 years ago
If content fits inside the frame and scrolling is set to scrolling="yes", then a 
"dimmed" scrollbar bar should be displayed. This is the way it works in Nav 4.7.
(Reporter)

Updated

18 years ago
QA Contact: petersen → lorca
->Frames
Assignee: clayton → pollmann
Component: HTML Element → HTMLFrames
QA Contact: lorca → petersen
(Reporter)

Comment 9

18 years ago
Changing QA contact to myself.
QA Contact: petersen → lorca
(Assignee)

Comment 10

18 years ago

*** This bug has been marked as a duplicate of 44306 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 11

18 years ago
Verified dupe of bug 44306: "Forced scrollbars don't show up."
Status: RESOLVED → VERIFIED

Updated

2 months ago
Product: Core → Core Graveyard
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.