Several strange focus problems with 3.0.9

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: alther, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.9) Gecko/2009040821 (CK-IBM) Firefox/3.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.9) Gecko/2009040821 (CK-IBM) Firefox/3.0.9

Since installing 3.0.9, I've run into at least 3 different focus issues.  In all these scenarios I have several Firefox windows open, each with several tabs.

1) Opening a link from an external application causes the link to be opened in the first(?) window, rather than the Firefox window with the last focus.  e.g. I open 3 Firefox windows in order: A, B & C.  B has focus.  I switch to another application and click on a link.  It launches the link in Firefox, but instead of opening it in a tab in window B, it opens it in window A.

2) Clicking on a Firefox window in the task bar causes it to restore behind the currently focused Firefox window.  e.g. I have 3 Firefox windows open: A, B & C.  A & C are minimized and B has focus.  I click on window A in the task bar and it restores, but it appears behind window B.

3) Unlocking the screensaver results in all Firefox windows restoring(?) and flashing to the front.  The actual Firefox window that last had focus appears at the back of the Z order.  This is a strange one.  e.g. I have 4 Firefox windows open: A, B, C & D.  Some may be minimized, but C has focus.  I then lock the screen and later come back and unlock it.  When I unlock it, all 4 Firefox windows flash to the front and window C is behind them all.

Unfortunately, I've not been able to figure out how to reproduce them, but they have all happened more than once.  I will continue to observe and if I come up with something reproducible, I'll comment.

I've never seen this behavior in any prior release of Firefox.

Reproducible: Sometimes

Steps to Reproduce:
None so far.  Just observe the behavior outlined in the 3 scenarios above.
Actual Results:  
Wrong window having focus or focus window appearing behind other Firefox windows.

Expected Results:  
Proper focus behavior (e.g. the way it worked in 3.0.8 or earlier).

None at the moment.
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

8 years ago
I still see occasional focus issues now and then, but nothing like I was seeing when I first reported this problem.  I can not reliably reproduce it either. I'll resolve it as requested.
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.