@title attribute no longer exposed on accDescription

VERIFIED FIXED in mozilla1.9.1

Status

()

--
major
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: MarcoZ, Assigned: surkov)

Tracking

({access, regression, verified1.9.1})

Trunk
mozilla1.9.1
access, regression, verified1.9.1
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

This is a regression from 3.0, where the title attribute's value was exposed as accDescription for links and images. I've confirmed it is broken on both mozilla-central and mozilla-1.9.1.
Works in:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081010 Minefield/3.1b2pre (.NET CLR 3.5.30729)

Is broken in:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081011 Minefield/3.1b2pre (.NET CLR 3.5.30729)

Regression range:
http://hg.mozilla.org/mozilla-central/shortlog/035cf0234960
Candidate: Bug 453591
Blocks: 453591
(Assignee)

Comment 3

10 years ago
Posted patch patch (obsolete) — Splinter Review
Assignee: nobody → surkov.alexander
Status: NEW → ASSIGNED
Attachment #374443 - Flags: review?(marco.zehe)
(Assignee)

Updated

10 years ago
Attachment #374443 - Flags: review?(david.bolter)
(Assignee)

Comment 4

10 years ago
clarification: previously GetTextFromRelationID returned NS_ERROR_FAILURE if there is no aria-describedby attribute, bug 453591 changed it to NS_OK.
Comment on attachment 374443 [details] [diff] [review]
patch

>+    function doTest()
>+    {
>+      // aria-label

Nit: Please include a test for aria-describedby as well. And change the comment accordingly.

>+  <img id="img1" title="title">
>+  <img id="img2" alt="name" title="description">

Nit: I'd prefer if the tags were closed with /> instead of >.
Comment on attachment 374443 [details] [diff] [review]
patch

r=me with those nits fixed. I confirmed that NVDA indeed again picks up the title for an image or link if asked for it.
Attachment #374443 - Flags: review?(marco.zehe) → review+
(In reply to comment #4)
> clarification: previously GetTextFromRelationID returned NS_ERROR_FAILURE if
> there is no aria-describedby attribute, bug 453591 changed it to NS_OK.

Heh, reminds me of bug 381048
Attachment #374443 - Flags: review?(david.bolter) → review+
Comment on attachment 374443 [details] [diff] [review]
patch

r=me if all a11y suite tests pass. (and with Marco's nits)
Comment on attachment 374443 [details] [diff] [review]
patch

Alexander, this is the part I'm confused about (in our IRC chat)

>   // 4. its title attribute already equals to its accName nsAutoString name; 
>   nsCOMPtr<nsIContent> content(do_QueryInterface(mDOMNode));
>-  if (!content) {
>-    return NS_ERROR_FAILURE;  // Node shut down
>-  }
>+  NS_ASSERTION(content, "No content of valid accessible!");
>+  if (!content)
>+    return NS_OK;
>+
If you return an error instead of the NS_OK as per our chat, that works for me.
(Assignee)

Comment 11

10 years ago
Posted patch patch2Splinter Review
with Marco and David wishes

Need to port on 1.9.1, regression fix
Attachment #374443 - Attachment is obsolete: true
Attachment #374454 - Flags: approval1.9.1?
Pushed on Alexander's behalf in changeset:
http://hg.mozilla.org/mozilla-central/rev/0390afd7fc62
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

10 years ago
Thank you, Marco!
Flags: in-testsuite+
Verified fixed in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090503 Minefield/3.6a1pre (.NET CLR 3.5.30729)
Status: RESOLVED → VERIFIED
Comment on attachment 374454 [details] [diff] [review]
patch2

a191=beltzner
Attachment #374454 - Flags: approval1.9.1? → approval1.9.1+
Pushed to mozilla-1.9.1 on Alexander's behalf in changeset:
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/ddc9a48a1509
Keywords: fixed1.9.1
Verified fixed in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090507 Shiretoko/3.5b5pre (.NET CLR 3.5.30729)
Keywords: fixed1.9.1 → verified1.9.1
Target Milestone: --- → mozilla1.9.1
You need to log in before you can comment on or make changes to this bug.