JSS test failed "It is taking too long for the threads to die."

REOPENED
Assigned to

Status

JSS
Tests
P1
normal
REOPENED
9 years ago
8 years ago

People

(Reporter: Nelson Bolyard (seldom reads bugmail), Assigned: glen beasley)

Tracking

Details

Attachments

(1 attachment, 2 obsolete attachments)

JSS test failed in one of the JSS tinderbox systems today.  System was:
trunk standard attic Linux 64bit DBG on 2009/04/24 03:30:19

============= SSL Ciphersuite JSS Server and JSS client both with Bypass On 
 ./startJssSelfServ.sh /export/tinderlight/data/attic_64_DBG/mozilla/dist/Linux2.4_x86_64_glibc_PTH_64_DBG.OBJ/../xpclass_dbg.jar /export/tinderlight/data/attic_64_DBG/mozilla/tests_results/jss/attic.1 localhost 8364 bypass /opt/jdk/1.6.0_01/Linux-amd64/jre/bin/java -d64 
/opt/jdk/1.6.0_01/Linux-amd64/jre/bin/java -d64 -classpath /export/tinderlight/data/attic_64_DBG/mozilla/dist/Linux2.4_x86_64_glibc_PTH_64_DBG.OBJ/../xpclass_dbg.jar org.mozilla.jss.tests.JSS_SelfServServer /export/tinderlight/data/attic_64_DBG/mozilla/tests_results/jss/attic.1 passwords localhost false 8364 bypass verboseoff &
main: jss library loaded
***FilePasswordCallback returns m1oZilla
JSS_SelfServServ localhost ready to accept connections on 8364

SSL Server is envoked using port 8364 
/opt/jdk/1.6.0_01/Linux-amd64/jre/bin/java -d64 -cp /export/tinderlight/data/attic_64_DBG/mozilla/dist/Linux2.4_x86_64_glibc_PTH_64_DBG.OBJ/../xpclass_dbg.jar org.mozilla.jss.tests.JSS_SelfServClient 2 -1 /export/tinderlight/data/attic_64_DBG/mozilla/tests_results/jss/attic.1 passwords localhost 8364 bypass verboseoff JSS 
Number of Threads to create: 2
Client connecting to server: localhost:8364
main: jss library loaded
***FilePasswordCallback returns m1oZilla
Testing Connection:localhost:8364
65 SSLSockets created.
Each created SSLSocket is reading/writing to the SSLServer.
Waiting till all threads are dead
ActiveCount56
ActiveCount20
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
ActiveCount1
It is taking too long for the threads to die. Exiting the program
Time taken: 4652 Millieseconds
JSSTEST_CASE 23 (SSL Ciphersuite JSS Server and JSS client both with Bypass On): FAILED return value 1
Created attachment 374846 [details]
Another thread die failure, after many exceptions

Here's a log of a similar, but not identical, failure from
trunk standard dositups SunOS/i386 32bit DBG on 2009/04/27 06:18:28
(Reporter)

Updated

9 years ago
OS: Linux → All
Priority: -- → P1
Hardware: x86_64 → All
(Assignee)

Updated

9 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

9 years ago
Created attachment 374921 [details] [diff] [review]
return success, when threads are taking too long to cleanup.

JSS_SelfServClient.java creates a thread for each configured cipher suites. After all threads have a successful connection and are reading/writing data, JSS_SelfServClient will close all connections, and wait for all threads to die. Sometime this takes too long, when it does end the program with success, so as not to make tinder box orange.
Attachment #374846 - Attachment is obsolete: true
Attachment #374921 - Flags: review?(nelson)
Comment on attachment 374921 [details] [diff] [review]
return success, when threads are taking too long to cleanup.

Glen, Shouldn't this simply return, instead of exiting?
(Assignee)

Comment 4

9 years ago
Created attachment 374940 [details] [diff] [review]
return from closeAllSockets regardless if all threads have died.

thanks for comment #3 nelson. We should return instead of exiting.
Attachment #374921 - Attachment is obsolete: true
Attachment #374940 - Flags: review?(nelson)
Attachment #374921 - Flags: review?(nelson)
(Reporter)

Updated

9 years ago
Attachment #374940 - Flags: review?(nelson) → review+
Comment on attachment 374940 [details] [diff] [review]
return from closeAllSockets regardless if all threads have died.

Yes, let's try this.
(Assignee)

Comment 6

9 years ago
new revision: 1.10; previous revision: 1.9
done
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Duplicate of this bug: 407343

Comment 8

8 years ago
Build: 20100526.1/nss-w2kp_WIN64

============= SSL Ciphersuite JSS Server and JSS client both with Bypass Off 
sh.exe ./startJssSelfServ.sh /e/security/securitytip/builds/20100526.1/nss-w2kp_WIN64/mozilla/dist/release/no-policy/classes_DBG/org/../xpclass_dbg.jar /e/security/securitytip/builds/20100526.1/nss-w2kp_WIN64/mozilla/tests_results/jss/NSS-W2KP.3 localhost 2906 bypassoff r:/jdk/1.6.0_01/WINNT_amd64/jre/bin/java.exe 
r:/jdk/1.6.0_01/WINNT_amd64/jre/bin/java.exe -classpath /e/security/securitytip/builds/20100526.1/nss-w2kp_WIN64/mozilla/dist/release/no-policy/classes_DBG/org/../xpclass_dbg.jar org.mozilla.jss.tests.JSS_SelfServServer /e/security/securitytip/builds/20100526.1/nss-w2kp_WIN64/mozilla/tests_results/jss/NSS-W2KP.3 passwords localhost false 2906 bypassoff verboseoff &
main: jss library loaded

SSL Server is invoked using port 2906 
r:/jdk/1.6.0_01/WINNT_amd64/jre/bin/java.exe -cp /e/security/securitytip/builds/20100526.1/nss-w2kp_WIN64/mozilla/dist/release/no-policy/classes_DBG/org/../xpclass_dbg.jar org.mozilla.jss.tests.JSS_SelfServClient 2 -1 /e/security/securitytip/builds/20100526.1/nss-w2kp_WIN64/mozilla/tests_results/jss/NSS-W2KP.3 passwords localhost 2906 bypassOff verboseoff JSS 
***FilePasswordCallback returns m1oZilla
JSS_SelfServServ localhost ready to accept connections on 2906
Number of Threads to create: 2
Client connecting to server: localhost:2906
main: jss library loaded
***FilePasswordCallback returns m1oZilla
Testing Connection:localhost:2906
65 SSLSockets created.
Each created SSLSocket is reading/writing to the SSLServer.
Waiting till all threads are dead
ActiveCount47
#
# An unexpected error has been detected by Java Runtime Environment:
#
#  Internal Error (4F533F57494E13123F414D4416140E4350500031), pid=668, tid=3008
#
# Java VM: Java HotSpot(TM) 64-Bit Server VM (1.6.0_01-b06 mixed mode)
# An error report file with more information is saved as hs_err_pid668.log
ActiveCount27
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#
JSSTEST_CASE 23 (SSL Ciphersuite JSS Server and JSS client both with Bypass Off): FAILED return value 1

This seems to be very similar failure (previously reported as a different bug, but was closed as duplicate of this one). Still crashes even after patch was committed, so I'm reopening this one.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
You need to log in before you can comment on or make changes to this bug.