Clean up autoconfig CSS

RESOLVED FIXED in Thunderbird 3.0rc1

Status

Thunderbird
Account Manager
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: philor, Assigned: philor)

Tracking

Trunk
Thunderbird 3.0rc1
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

9 years ago
Having gone through several iterations of UI, the autoconfig CSS has a fair number of selectors that don't select anything, and probably some that do select, but could use improvement.
(Assignee)

Comment 1

8 years ago
Created attachment 403972 [details] [diff] [review]
Cleanup on aisle 1

Bet you wish now you'd taken the bug, so you could have had the minor tedium of writing it instead of the extreme tedium of having to stay awake clear through checking it :)
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #403972 - Flags: review?(bwinton)
Two questions, while I build the Ubuntu and Windows versions:

>+++ b/mail/themes/gnomestripe/mail/accountCreation.css
>-vbox.settings {
>-  padding: 1em;
>-}

Should we also remove the class from 
mailnews/base/prefs/content/accountcreation/emailWizard.xul
line 221:      <groupbox id="settingsbox" class="settings">
?

>-vbox.initialSettings textbox {
>-  width: 280px;
>-}

Should we also remove the class from 
mailnews/base/prefs/content/accountcreation/emailWizard.xul
line 147:    <groupbox class="initialSettings">
?

Thanks,
Blake.
(Assignee)

Comment 3

8 years ago
Created attachment 404662 [details] [diff] [review]
Cleanup on aisle 2

Good call - switched initialSettings to an id in case a third-party theme needs it, dropped the class="settings".
Attachment #403972 - Attachment is obsolete: true
Attachment #404662 - Flags: review?(bwinton)
Attachment #403972 - Flags: review?(bwinton)
Comment on attachment 404662 [details] [diff] [review]
Cleanup on aisle 2

Okay, I tested it on XP, OS X, and Ubuntu, and there were no layout changes caused by this, and the changes look good, so I say go for it.

r=me.
Attachment #404662 - Flags: review?(bwinton) → review+
(Assignee)

Comment 5

8 years ago
http://hg.mozilla.org/comm-central/rev/d23d96551e9f
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0rc1
You need to log in before you can comment on or make changes to this bug.