"Assertion failure: OBJ_SCOPE(obj)->object == pobj," (at jsobj.cpp) in Thunderbird

RESOLVED FIXED

Status

()

Core
JavaScript Engine
--
critical
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: gkw, Assigned: Igor Bukanov)

Tracking

({assertion, fixed1.9.1, testcase})

Trunk
x86
Mac OS X
assertion, fixed1.9.1, testcase
Points:
---
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
I was using an updated debug Thunderbird with a Gmail POP account, and I just sent it an email using another webmail account from somewhere else, then I saw this assertion trapped in gdb. Also, I have Growl installed if that matters.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b5pre) Gecko/20090425 Lightning/1.0pre Shredder/3.0b3pre

=====

Assertion failure: OBJ_SCOPE(obj)->object == pobj, at /Users/fuzz3/comm-central/mozilla/js/src/jsobj.cpp:4080

Program received signal SIGTRAP, Trace/breakpoint trap.
JS_Assert (s=0x40bc54 "OBJ_SCOPE(obj)->object == pobj", file=0x40b220 "/Users/fuzz3/comm-central/mozilla/js/src/jsobj.cpp", ln=4080) at /Users/fuzz3/comm-central/mozilla/js/src/jsutil.cpp:69
69          abort();
(gdb) bt
#0  JS_Assert (s=0x40bc54 "OBJ_SCOPE(obj)->object == pobj", file=0x40b220 "/Users/fuzz3/comm-central/mozilla/js/src/jsobj.cpp", ln=4080) at /Users/fuzz3/comm-central/mozilla/js/src/jsutil.cpp:69
#1  0x0030c41e in js_FindPropertyHelper (cx=0x106ca00, id=463071748, cacheResult=1, objp=0xbfffa80c, pobjp=0xbfffa808, propp=0xbfffa7ec) at /Users/fuzz3/comm-central/mozilla/js/src/jsobj.cpp:4080
#2  0x002d8fc0 in js_Interpret (cx=0x106ca00) at /Users/fuzz3/comm-central/mozilla/js/src/jsinterp.cpp:4156
#3  0x002f4962 in js_Invoke (cx=0x106ca00, argc=3, vp=0x1c601980, flags=0) at jsinterp.cpp:1373
#4  0x0028699f in array_extra (cx=0x106ca00, mode=FOREACH, argc=3, vp=0x1c60195c) at /Users/fuzz3/comm-central/mozilla/js/src/jsarray.cpp:3051
#5  0x00286c2e in array_forEach (cx=0x106ca00, argc=1, vp=0x1c60195c) at /Users/fuzz3/comm-central/mozilla/js/src/jsarray.cpp:3107
#6  0x002e0541 in js_Interpret (cx=0x106ca00) at /Users/fuzz3/comm-central/mozilla/js/src/jsinterp.cpp:5100
#7  0x002f4962 in js_Invoke (cx=0x106ca00, argc=4, vp=0x1d1c8b80, flags=0) at jsinterp.cpp:1373
#8  0x00e46bac in nsXPCWrappedJSClass::CallMethod (this=0x1cd82990, wrapper=0x1d1c8bf0, methodIndex=4, info=0x1252468, nativeParams=0xbfffb894) at /Users/fuzz3/comm-central/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp:1614
#9  0x00e3ddaf in nsXPCWrappedJS::CallMethod (this=0x1d1c8bf0, methodIndex=4, info=0x1252468, params=0xbfffb894) at /Users/fuzz3/comm-central/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp:561
#10 0x005652f2 in PrepareAndDispatch (self=0x1d3e9480, methodIndex=4, args=0xbfffb9b4) at /Users/fuzz3/comm-central/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_unixish_x86.cpp:93
#11 0x005653a3 in nsXPTCStubBase::Stub4 (this=0x1d3e9480) at xptcstubsdef.inc:2
#12 0x0056500f in NS_InvokeByIndex_P (that=0x1d3e9480, methodIndex=4, paramCount=4, params=0xbfffbb94) at /Users/fuzz3/comm-central/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_unixish_x86.cpp:179
#13 0x00e4d1b8 in XPCWrappedNative::CallMethod (ccx=@0xbfffbde0, mode=XPCWrappedNative::CALL_METHOD) at /Users/fuzz3/comm-central/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp:2450
#14 0x00e5818d in XPC_WN_CallMethod (cx=0x106ca00, obj=0x1c247800, argc=4, argv=0x1d1c8b60, vp=0xbfffbf00) at /Users/fuzz3/comm-central/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp:1583
#15 0x002f4919 in js_Invoke (cx=0x106ca00, argc=4, vp=0x1d1c8b58, flags=2) at jsinterp.cpp:1365
#16 0x002e06c1 in js_Interpret (cx=0x106ca00) at /Users/fuzz3/comm-central/mozilla/js/src/jsinterp.cpp:5132
#17 0x002f4962 in js_Invoke (cx=0x106ca00, argc=3, vp=0x1d1c8b38, flags=0) at jsinterp.cpp:1373
#18 0x00e46bac in nsXPCWrappedJSClass::CallMethod (this=0x1dbe0590, wrapper=0x1c84c810, methodIndex=38, info=0x1243cd8, nativeParams=0xbfffcb04) at /Users/fuzz3/comm-central/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp:1614
#19 0x00e3ddaf in nsXPCWrappedJS::CallMethod (this=0x1c84c810, methodIndex=38, info=0x1243cd8, params=0xbfffcb04) at /Users/fuzz3/comm-central/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp:561
#20 0x005652f2 in PrepareAndDispatch (self=0x1cd96ef0, methodIndex=38, args=0xbfffcc24) at /Users/fuzz3/comm-central/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_unixish_x86.cpp:93
#21 0x00565e87 in nsXPTCStubBase::Stub38 (this=0x1cd96ef0) at xptcstubsdef.inc:36
#22 0x0056500f in NS_InvokeByIndex_P (that=0x1cd96ef0, methodIndex=38, paramCount=3, params=0xbfffcdf4) at /Users/fuzz3/comm-central/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_unixish_x86.cpp:179
#23 0x00e4d1b8 in XPCWrappedNative::CallMethod (ccx=@0xbfffd040, mode=XPCWrappedNative::CALL_METHOD) at /Users/fuzz3/comm-central/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp:2450
#24 0x00e5818d in XPC_WN_CallMethod (cx=0x106ca00, obj=0x12ec18e0, argc=3, argv=0x1d1c8b1c, vp=0xbfffd160) at /Users/fuzz3/comm-central/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp:1583
#25 0x002f4919 in js_Invoke (cx=0x106ca00, argc=3, vp=0x1d1c8b14, flags=2) at jsinterp.cpp:1365
#26 0x002e06c1 in js_Interpret (cx=0x106ca00) at /Users/fuzz3/comm-central/mozilla/js/src/jsinterp.cpp:5132
#27 0x002f4962 in js_Invoke (cx=0x106ca00, argc=3, vp=0x1d1c8af0, flags=0) at jsinterp.cpp:1373
#28 0x00e46bac in nsXPCWrappedJSClass::CallMethod (this=0x16caf200, wrapper=0x16caf4c0, methodIndex=5, info=0x12134f8, nativeParams=0xbfffdd64) at /Users/fuzz3/comm-central/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp:1614
#29 0x00e3ddaf in nsXPCWrappedJS::CallMethod (this=0x16caf4c0, methodIndex=5, info=0x12134f8, params=0xbfffdd64) at /Users/fuzz3/comm-central/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp:561
#30 0x005652f2 in PrepareAndDispatch (self=0x16caf8c0, methodIndex=5, args=0xbfffde84) at /Users/fuzz3/comm-central/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_unixish_x86.cpp:93
#31 0x005653f5 in nsXPTCStubBase::Stub5 (this=0x16caf8c0) at xptcstubsdef.inc:3
#32 0x1bc96c01 in nsAutoSyncManager::DownloadMessagesForOffline (this=0x16caf0e0, aAutoSyncStateObj=0x1fe5aad0, aSizeLimit=0) at /Users/fuzz3/comm-central/mailnews/imap/src/nsAutoSyncManager.cpp:950
#33 0x1bc96ec6 in nsAutoSyncManager::OnDownloadQChanged (this=0x16caf0e0, aAutoSyncStateObj=0x1fe5aad0) at /Users/fuzz3/comm-central/mailnews/imap/src/nsAutoSyncManager.cpp:1168
#34 0x1bc92af7 in nsAutoSyncState::PlaceIntoDownloadQ (this=0x1fe5aad0, aMsgKeyList=@0xbfffe07c) at /Users/fuzz3/comm-central/mailnews/imap/src/nsAutoSyncState.cpp:192
#35 0x1bc92b96 in nsAutoSyncState::OnNewHeaderFetchCompleted (this=0x1fe5aad0, aMsgKeyList=@0xbfffe07c) at /Users/fuzz3/comm-central/mailnews/imap/src/nsAutoSyncState.cpp:427
#36 0x1bc1e003 in nsImapMailFolder::HeaderFetchCompleted (this=0x1eef5330, aProtocol=0x1331600) at /Users/fuzz3/comm-central/mailnews/imap/src/nsImapMailFolder.cpp:5269
#37 0x0056500f in NS_InvokeByIndex_P (that=0x1eef5430, methodIndex=31, paramCount=1, params=0x1edd1c90) at /Users/fuzz3/comm-central/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_unixish_x86.cpp:179
#38 0x00553a50 in nsProxyObjectCallInfo::Run (this=0x1d39ddb0) at /Users/fuzz3/comm-central/mozilla/xpcom/proxy/src/nsProxyEvent.cpp:181
#39 0x00548b0e in nsThread::ProcessNextEvent (this=0x814840, mayWait=0, result=0xbfffe214) at /Users/fuzz3/comm-central/mozilla/xpcom/threads/nsThread.cpp:510
#40 0x004d1f58 in NS_ProcessPendingEvents_P (thread=0x814840, timeout=20) at nsThreadUtils.cpp:180
#41 0x11c294eb in nsBaseAppShell::NativeEventCallback (this=0x83bb40) at /Users/fuzz3/comm-central/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:121
#42 0x11bdec18 in nsAppShell::ProcessGeckoEvents (aInfo=0x83bb40) at /Users/fuzz3/comm-central/mozilla/widget/src/cocoa/nsAppShell.mm:405
#43 0x962df5f5 in CFRunLoopRunSpecific ()
#44 0x962dfcd8 in CFRunLoopRunInMode ()
#45 0x9203b2c0 in RunCurrentEventLoopInMode ()
#46 0x9203b0d9 in ReceiveNextEventCommon ()
#47 0x9203af4d in BlockUntilNextEventMatchingListInMode ()
#48 0x93de7d7d in _DPSNextEvent ()
#49 0x93de7630 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] ()
#50 0x93de066b in -[NSApplication run] ()
#51 0x11bdcd04 in nsAppShell::Run (this=0x83bb40) at /Users/fuzz3/comm-central/mozilla/widget/src/cocoa/nsAppShell.mm:716
#52 0x128a538e in nsAppStartup::Run (this=0x855550) at /Users/fuzz3/comm-central/mozilla/toolkit/components/startup/src/nsAppStartup.cpp:193
#53 0x000e2d1f in XRE_main (argc=1, argv=0xbffff850, aAppData=0x80e700) at /Users/fuzz3/comm-central/mozilla/toolkit/xre/nsAppRunner.cpp:3298
#54 0x0000285f in main (argc=1, argv=0xbffff850) at /Users/fuzz3/comm-central/mail/app/nsMailApp.cpp:103
(gdb) frame 1
#1  0x0030c41e in js_FindPropertyHelper (cx=0x106ca00, id=463071748, cacheResult=1, objp=0xbfffa80c, pobjp=0xbfffa808, propp=0xbfffa7ec) at /Users/fuzz3/comm-central/mozilla/js/src/jsobj.cpp:4080
4080                        JS_ASSERT(OBJ_SCOPE(obj)->object == pobj);
(gdb) call JS_GetFramePC(cx, cx->fp)
$1 = (jsbytecode *) 0x16c31b89 ")"
(gdb) call JS_PCToLineNumber(cx, cx->fp->script, $1)
$2 = 276
(gdb) p cx->fp->script->filename
$3 = 0x16c2ffc1 "chrome://messenger/content/mailWindow.js"

Here's an MXR link to the file: 
http://mxr.mozilla.org/comm-central/source/mail/base/content/mailWindow.js#276
(Reporter)

Updated

9 years ago
Summary: Assertion failure: OBJ_SCOPE(obj)->object == pobj, (at jsobj.cpp) → Assertion failure: OBJ_SCOPE(obj)->object == pobj, (at jsobj.cpp) with Thunderbird and POP account
(Reporter)

Comment 1

9 years ago
Created attachment 374591 [details]
Zipped .eml testcase

I was testing bug 210943 and the email testcase attached is part of these adventures.

I'm not sure if the assertion is specific to this testcase or not - seems reproducible for me.
(Reporter)

Updated

9 years ago
Keywords: testcase
(Assignee)

Updated

9 years ago
Assignee: general → igor
(Reporter)

Updated

9 years ago
Summary: Assertion failure: OBJ_SCOPE(obj)->object == pobj, (at jsobj.cpp) with Thunderbird and POP account → "Assertion failure: OBJ_SCOPE(obj)->object == pobj," (at jsobj.cpp) with Thunderbird and POP account
(Reporter)

Comment 2

9 years ago
Nominating blocking1.9.1 because this is starting to occur fairly often in debug Thunderbird. bienvenu reports he sees the assertion too albeit with a slightly different stack.
Flags: blocking1.9.1?
(Assignee)

Comment 3

9 years ago
This bug and the  bug 491013 could be two faces of the same problem. Even if this would not be the case, then at least asserts in the patch for the bug 491013 should allow to capture the problem significantly earlier than the current assert coverage allows.
Depends on: 491013
(Reporter)

Comment 4

9 years ago
Kent sees this in bug 491013 comment #11 with IMAP as well.
Summary: "Assertion failure: OBJ_SCOPE(obj)->object == pobj," (at jsobj.cpp) with Thunderbird and POP account → "Assertion failure: OBJ_SCOPE(obj)->object == pobj," (at jsobj.cpp) in Thunderbird

Updated

9 years ago
Flags: blocking1.9.1? → blocking1.9.1+

Comment 5

9 years ago
still seeing this?
(Reporter)

Comment 6

9 years ago
(In reply to comment #5)
> still seeing this?

I think bug 491013's fix needs to be propagated to mozilla-1.9.1 first..

Comment 7

9 years ago
this is a trunk bug...
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 8

9 years ago
bug 491013 is fixed1.9.1
Keywords: fixed1.9.1
You need to log in before you can comment on or make changes to this bug.