Closed Bug 49020 Opened 20 years ago Closed 19 years ago

CSS and FRAMESET

Categories

(Core :: Layout: Images, Video, and HTML Frames, defect, P3)

x86
Other
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: tapio.markula, Assigned: pollmann)

Details

I don't know, if Mozilla support FRAME and FRAMESET. I hope, that future Netscape 6.0 will support them like MS IE does. To support them is the ONLY way to get SIMILAR borders to IE 5.x and NN 6.x browsers, because NN scroll borders among document, if they are set to other elemens.

This CSS could help all border problems in nested framesets:

frameset.frameset {black;border:1px solid #636}

Because %coreatts; a allow to FRAME and FRAMESET, MS IE doesn't do nothing
against the official HTML 4.x/XHTML 1.x recommendations.
I have proposed the same matter to Opera Software, because also Opera scroll borders, if they are set to element BODY (I know, that Opera and Mozilla do according to CSS2 spec. and MS IE not).

I have not for a long time tested Mozilla because last tests were so big
disappointments - Mozilla was too unreliable and it doesn have serios display problems. I have now informed, that only MS IE support Internationalization attributes 'lang' and 'dir'. If NS 6.x supports them also,
it is good, but I just have not tested (I tested <BDO dir... with Opera, but
it doesn't support 'dir').

Brian Wilson's Index DOT Html doesn't list yet Netscape 6.x and I can't get yet proper information about it in:
http://www.nic.fi/~tapio1/Teaching/Attributes.html + Attributes2.html

Also following elements, which have %coreattrs; is not supported with CSS in any browser, which I have tested even if it would be very reasonable:
MAP
AREA
BR (IE and Opera support it in XML documents, but not in HTML)

Also supporting of form elements could be better.
Huh? What bug is it that you are reporting? One bug per bug number please.
tapio.markula@nic.fi, thank you for your help in testing mozilla and reporting
bugs.  Please take a look at the bug writing guidelines
http://www.mozilla.org/quality/bug-writing-guidelines.html and consider using
the Bugzilla Helper to report future bugs.
http://www.mozilla.org/quality/help/bug-form.html
Can you isolate this report to a single issue and comment with the kinds of
information found int he bug reporting guidelines.  Thanks again.
Closing as invalid for lack of a response from the reporter.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → INVALID
QA Contact update
QA Contact: petersen → amar
Mass removing self from CC list.
Now I feel sumb because I have to add back. Sorry for the spam.
Product: Core → Core Graveyard
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.