'Accept cookies from site' option disabling when firefox quits

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Phill Pover, Unassigned)

Tracking

3.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.0.9) Gecko/2009040820 Firefox/3.0.9
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.0.9) Gecko/2009040820 Firefox/3.0.9

Whenever I restart Firefox, I cannot log in to any websites that require cookies. After a little hunting I found that the option 'Accept cookies from site' turns itself off whenever I shut Firefox down. There is no crash report from Firefox, so I assume it is closing correctly. This has only started happening since upgrading to Firefox 3.0.9

Reproducible: Always

Steps to Reproduce:
1. Start up Firefox and try to log in to any site which requires cookies (e.g. www.reddit.com). This will fail and redirect me to the homepage again to log it.
2. Check Preferences > Privacy > Cookies and 'Accept cookies from sites' is turned off.
3. Turn on above option and restart Firefox.
Actual Results:  
'Accept cookies from sites' option is off again after restarting Firefox.

Expected Results:  
'Accept cookies from sites' option should remain selected between restarts.

Extension:
All-in-One Sidebar 0.7.10
DejaClick by Alertsite 1.3.3.5
Greasemonkey 0.8.20090123.1
NoScript 1.9.1.8
Socialite 1.3.2.1
Stealther 1.0.6
Stylish 0.5.9
Torbutton 1.2.1 (Tor is not active when this happens)
Tree Style Tab 0.7.2009040901
TV-Fox 1.0.8
WOT 20090325
YouTube Comment Snob 1.3
Maybe due to an add-on? Please try safe-mode: http://support.mozilla.com/en-US/kb/Safe+Mode
and if it still doesn't work, read: http://support.mozilla.com/lt/kb/Preferences+are+not+saved
(Reporter)

Comment 2

9 years ago
Sorry, my fault. Had accidentally turned on Stealther without realising. I'd installed it a while ago but forgotten about it and also didn't realise what it was.

Thanks for you help anyway.
Great that it's working now. Resolving WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 3.0 Branch
You need to log in before you can comment on or make changes to this bug.