Status

Skywriter
Editor
--
enhancement
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Chris J, Unassigned)

Tracking

Dependency tree / graph

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Build Identifier: 

Expand jslint setting to enable options, e.g. jslint forin=true safe=true


Reproducible: Always
(Reporter)

Updated

9 years ago
Depends on: 473328, 486949
This is a logical extension of bug 486949, so confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86 → All
Target Milestone: --- → Future
Version: unspecified → Trunk
Target Milestone: Future → ---
(Reporter)

Comment 2

9 years ago
Created attachment 377867 [details] [diff] [review]
adds jslint options support via "set jslint {}"

This patch adds jslint options support. See http://www.jslint.com/lint.html for all the available options. They are entered as a json string to the "jslint" setting, for example type this in the command line:

"set jslint {eqeqeq:true}" 

to create a warning for all uses of double equals in javascript (since triple equals is safer).

I've tried to make the code extensible by treating it as one of a number of "parseOptions" that could be run for different languages.

Comment 3

9 years ago
The patch collided with the other one, so I did it by hand and it is in tip. Please give it a once over!
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.