[autoconfig] New Quick Account doesn't support Google Apps

VERIFIED FIXED

Status

Thunderbird
Account Manager
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: Henrik Gemal, Assigned: bwinton)

Tracking

(Depends on: 1 bug)

Dependency tree / graph
Bug Flags:
blocking-thunderbird3 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact])

(Reporter)

Description

9 years ago
All of my domains including my work domain are using Google Apps. But the Quick Account doesn't seem to be able to lookup my Google Apps mail configuration.

I enter:
mail: henrik@gemal.dk

and it gives my "imap.gemal.dk" which isn't correct. It should use "imap.gmail.com" since my mx records points to google.com.

Damn.. I really really hoped that the new quick setup would support Google Apps. :(
(Reporter)

Comment 1

9 years ago
My company email "gemal[at]dinnerbooking.com" never finishes :(
Just getting the spinner in the end

Comment 2

9 years ago
xref bug 458770 (for the old account setup)
(Reporter)

Updated

9 years ago
Summary: New Quick Account doesn't support Google Apps → [autoconfig] New Quick Account doesn't support Google Apps

Comment 3

9 years ago
We're not using mx records, afaik, so this isn't surprising.

Is dinnerbooking.com reachable? What are the server names?
(Reporter)

Comment 4

9 years ago
dinnerbooking.com is a standard Google Apps domain.

To access my mail I can use mail.dinnerbooking.com as webmail or imap.gmail.com as IMAP.

I was just hoping that the quick setup somehow supported Google Apps

The problem is that if I setup imap.dinnerbooking.com to point to imap.gmail.com I get a security warning due to certificate mismatch.
Blocks: 422814
Duplicate of this bug: 505267

Comment 6

9 years ago
Why can't we simply use the new gmail wizard but enter our full domain? Don't automatically enter "gmail.com" at the end for people. Then anything without gmail.com is a google apps domain. 

Or have a checkbox to expand the wizard if needed for a google apps domain?
Blocks: 458770

Comment 7

8 years ago
The out-of-the-box experience of this is very BAD.
I tried to setup an IMAP account for user.name@googlemail.com and just couldn't get it to work using autoconfig.

It even claimed all account settings were right and then still failed on "Create Account" anyway, claiming username/password mismatch (which I am sure wasn't the case).

Using manual setup, it worked.
One thing that I noticed was different is that autoconfig uses port 465 for smtp.googlemail.com, whereas google help recommends to use port 587 (even though I'm not sure if that is recent information - http://mail.google.com/support/bin/answer.py?hl=de&answer=77662)
(Assignee)

Updated

8 years ago
Assignee: nobody → bwinton
Flags: blocking-thunderbird3?
(In reply to comment #7)
> The out-of-the-box experience of this is very BAD.
> I tried to setup an IMAP account for user.name@googlemail.com and just couldn't
> get it to work using autoconfig.
> 
> It even claimed all account settings were right and then still failed on
> "Create Account" anyway, claiming username/password mismatch (which I am sure
> wasn't the case).

This is a bit off topic of this bug but I just tried this with my own gmail account and it worked for me.  Can you file a separate bug for this with some steps to reproduce?
 
> Using manual setup, it worked.
> One thing that I noticed was different is that autoconfig uses port 465 for
> smtp.googlemail.com, whereas google help recommends to use port 587 (even
> though I'm not sure if that is recent information -
> http://mail.google.com/support/bin/answer.py?hl=de&answer=77662)

I'm not sure which is the correct port but 465 does work.  Can you file another bug for this?  It would be good to investigate which is the right port.

Comment 9

8 years ago
(In reply to comment #8)
> (In reply to comment #7)
> This is a bit off topic of this bug but I just tried this with my own gmail
> account and it worked for me.  Can you file a separate bug for this with some
> steps to reproduce?

Thanks Bryan, you're right, it works on clean profile. So it was because the other known bugs currently spoiling autoconfig. No need for new bug.

> I'm not sure which is the correct port but 465 does work.  Can you file
> another bug for this?  It would be good to investigate which is the right
> port.

Filed bug 521101 -  [autoconfig] Examine which is right port for smtp.googlemail.com

Updated

8 years ago
Whiteboard: [no l10n impact]
Without steps to reproduce, this can't be a blocker.  Feel free to renominate if/when such arise...
Flags: blocking-thunderbird3? → blocking-thunderbird3-

Comment 11

8 years ago
Could someone check these STR (if they actually fail)?

STR
1) In quick account setup, enter your data with a non-.com localized(!) google mail address, like
- gemal.dk
- gmail.de (old accounts only, not sure if they still exist)
- googlemail.de

2) let quick account do the rest for you, confirm everything and DON'T change, cancel or go back on anything(!)

Actual results:
3) see how it fails (not sure if it actually does, but I think it did), because quick setup tries localized imap servers which won't work:
- imap.gemal.dk
- imap.googlemail.de

Expected results:
4) Quick setup should honor google's centralized nature and should always use
"imap.gmail.com" since the mx records all point to google.com (see comment #0), no matter if your actual address is localized or not

Comment 12

8 years ago
step 1) addresses look like: username@gemal.dk etc...

Updated

8 years ago
Keywords: qawanted
(In reply to comment #10)
> Without steps to reproduce, this can't be a blocker.  Feel free to renominate
> if/when such arise...

You don't need steps to reproduce , you need a domain that is hosted on google. take hirlimann.net for instance - if needed I can provide a test account there.

STR :
 1) Enter ludovic hirlimann, ludovic@hirlimann.net , hidden password
 2) press create account

Results , settings are unusable.

Expected results , I can connect to my gmail domain.

Comment #6 is a goode idea for a workaround. Another would be to check is mail.google.com/hosted/domain.com is a 404 or not. if 404 then not hosted or something like that.

Comment #7 has nothing to do with google hosted domain and belongs in another bug - where we should support countries where google doesn't use gmail for legal reasons. comment 8, and 9 are follow up on the OT comment 7.

The main reason this doesn't block is that DNS support is necko can't read mx records or something like that. (see bug 342242 for the enh.) Core necko bug is 356104 - with that fix this would be easily implementable.
Keywords: qawanted

Comment 14

8 years ago
The idea fix is for this is Step 2 - fetch config directly from ISP - from 
<https://wiki.mozilla.org/Thunderbird:Autoconfiguration#Implementation>

Comment 15

8 years ago
Filed bug 534722 about that.
Depends on: 534722

Comment 16

8 years ago
I can confirm this in version 3.1
[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgAccountManager.createIncomingServer]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/accountcreation/verifyConfig.js :: verifyConfig :: line 84"  data

Even when setting up manually
  Installed: 3.1~a1~hg20091221r4576+nobinonly-0ubuntu1~umd1

Comment 17

8 years ago
BUGabundo, that is another problem independent from this bug.

Comment 18

8 years ago
Sorry, I was pointed here by a triager.
Ben could you point me in the right direction?

Comment 19

8 years ago
BUGabundo, please just file a new bug, but with more information (exact steps to reproduce etc.).
Depends on: 545495

Updated

8 years ago
Depends on: 342242
Duplicate of this bug: 555314
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
V with hirlimann.net
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.