bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Firefox was unable to verify the integrity of the incremental update it downloaded... Then it looped




Application Update
9 years ago
9 years ago


(Reporter: Cris, Unassigned)


Firefox Tracking Flags

(Not tracked)



(4 attachments)



9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv: Gecko/2009032608 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv: Gecko/2009032608 Firefox/3.0.8

I'm on Firefox 3.0.8 and it checked for updates automatically, told me there's 3.0.9 available.  So I said yes, go for it.
But in the Downloading Update, Software Update window. It looped on connecting to the update server. 
The Red caution message is "Firefox was unable to verify the integrity of the incremental update it downloaded, so it is now downloading the complete update package" 
But this didn't work, just gave me the Firefox rotating ball, so guess there's a problem somewhere...
I Quit Firefox and tried again, to ensure it happened a second time.  And it did

Reproducible: Always

Steps to Reproduce:
1.Check for updates
2.Click yes to update to 3.0.9
Actual Results:  
Downloading Update window looped.

Expected Results:  
Update as normal to 3.0.9

If I could see a way of attaching a jpg to this bug report to show you the window, I would.  So if there is a way to do this, it's not obvious...
On reading the next text, maybe there's a way after I file the bug, but it makes more sense to do it with it...

Comment 1

9 years ago
Created attachment 374780 [details]
png of still looping Downloading update window

The software Update window is still looping although I've now spent maybe 10-15 minutes filing this bug...
Please attach the following files from inside the Firefox package
Component: Installer → Application Update
Product: Firefox → Toolkit
QA Contact: installer → application.update

Comment 3

9 years ago
Created attachment 374797 [details]

update/last-update.log as requested.
But the auto-detect failed, yet it is called .log, so hope I have the right file
And then it cancelled the file specification so I had to choose it again...
Third try.  enter manually failed, so I'll guess it's a text file, hope that's right

Comment 4

9 years ago
Created attachment 374798 [details]
active-update.xml as requested

active-update.xml as requested

Comment 5

9 years ago
Created attachment 374799 [details]
updates.xml as requested

updates.xml as requested

Comment 6

9 years ago
On reflection, I should say that I use Little Snitch.  This allows me to see what outgoing network calls are made from an application and to allow or disallow them.  When Firefox upgrade failed the first time, Little Snitch was enabled.
For the second attempt I had disabled Little Snitch in case blocked network activity was the cause of the problem.  But the problem still repeated after Firefox Quit and Reload. So Little Snitch is not the cause second time round, although it could theoretically be first time.
Given in the interests of full disclosure. :-)
The download could have been corrupted by little snitch and then cached. Can you try reproducing without any interaction from little snitch?

Comment 8

9 years ago
I have just suspended Little Snitch. Then loaded Firefox which said 3.0.10, not 3.0.9,  was available.  So I said yes and downloaded it and installed it without any problem.
Mind you, since Little Snitch only affects outgoing communications, but NOT incoming ones, ie TO other sites but not FROM them,  I'm a bit dubious about the corrupted download hypothesis. 
But anyway, this has now worked, and so this bug is obsolete.
Thanks guys, I'm now a happy camper.
Tuesday, 2009/04/28 at 8.31 pm


9 years ago
Last Resolved: 9 years ago
Resolution: --- → FIXED
It very well might not have been little snitch and could just as easily have been a temporary network issue... in either case there is little that can be done to resolve this from the app update component and the vast majority of people don't experience this problem.
You need to log in before you can comment on or make changes to this bug.