Corruption of start window

RESOLVED FIXED in mozilla1.9.2a1

Status

()

defect
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: hiro, Assigned: hiro)

Tracking

({mobile})

Trunk
mozilla1.9.2a1
ARM
Windows Mobile 6 Professional
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Posted image screenshot
Memory allocation failure occurs at 
http://mxr.mozilla.org/mozilla-central/source/gfx/thebes/src/gfxImageSurface.cpp#80

I guess jemalloc build is broken.
Component: General → jemalloc
Product: Fennec → Core
QA Contact: general → jemalloc
not surprisingly, it is huge_malloc that is failing
Posted patch A patchSplinter Review
I found a mistake in configure.in.

The first part of this fix is not concerned to this issue but I think it should be fixed.

I am building with this fix now.
Assignee: nobody → ikezoe
2nd part looks right not sure about the first
The first part was confusable to me.

I confirmed the patch fixes this issue now.
Because MOZ_MEMORY_WINCE6 is being defined, JEMALLOC_USES_MAP_ALIGN isn't getting defined so we don't call pages_map_align from huge_malloc.  This results in huge_malloc failing.
Attachment #374834 - Flags: superreview?(pavlov)
Attachment #374834 - Flags: review?(vladimir)
By the way, the comment in jemalloc.c should also be fixed.

--- a/memory/jemalloc/jemalloc.c	Tue Apr 28 01:37:02 2009 +0200
+++ b/memory/jemalloc/jemalloc.c	Tue Apr 28 13:08:14 2009 +0900
@@ -6118,17 +6118,17 @@ malloc_shutdown()
  * zone infrastructure.
  */
 #ifdef MOZ_MEMORY_DARWIN
 #  define ZONE_INLINE	inline
 #else
 #  define ZONE_INLINE
 #endif
 
-/* Mangle standard interfaces on Darwin and Windows CE, 
+/* Mangle standard interfaces on Darwin, 
    in order to avoid linking problems. */
 #if defined(MOZ_MEMORY_DARWIN)
 #define	malloc(a)	moz_malloc(a)
 #define	valloc(a)	moz_valloc(a)
 #define	calloc(a, b)	moz_calloc(a, b)
 #define	realloc(a, b)	moz_realloc(a, b)
 #define	free(a)		moz_free(a)
pushed http://hg.mozilla.org/mozilla-central/rev/dc2dc621fd34
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Attachment #374834 - Flags: superreview?(pavlov)
Attachment #374834 - Flags: superreview+
Attachment #374834 - Flags: review?(vladimir)
Attachment #374834 - Flags: review+
Flags: in-testsuite-
Target Milestone: --- → mozilla1.9.2a1
You need to log in before you can comment on or make changes to this bug.