Redraw the scrolled down element, the scroll bar will be jumping (Firefox 3 only, Firefox 2 works well)

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
9 years ago
5 years ago

People

(Reporter: Jumper Chen, Unassigned)

Tracking

3.6 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [FF3.x])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)

Upon clicking the button the scrollbar will jump from it's current position to the value we set. (only Firefox 3.0.x and Firefox 3.5 Beta) Others work well (like IE, Firefox 2, Opera)

Reproducible: Always

Steps to Reproduce:
1.Open the example.html file
2.Quick click on the button to redraw the element (you have to click many time because the sample too simple).
3.
Actual Results:  
sometimes, you will see the scroll bar is jumping.

Expected Results:  
you should see the scroll bar stay on the position we set.
(Reporter)

Comment 1

9 years ago
Created attachment 374875 [details]
test case
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0 Branch

Comment 2

8 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a3pre) Gecko/20100305 Minefield/3.7a3pre (.NET CLR 3.5.30729)

please reopen if you see in current ff trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

8 years ago
Hi,
I test the issue with Firefox 3.5.8 and it still remains.
I click the button 9~10 times(click rapidly) and the scrollbar will jump once.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
This is a mass search for Firefox General bugs filed against version 3.0 that are UNCO and have not been changed for 200 days.

Reporter, please update to Firefox 3.6.10 or alter. Firefox 3.0 is no longer supported and is no longer receiving updates. After you update, please create a fresh profile, http://support.mozilla.com/kb/managing+profiles, and test to see if your bug still exists. If you still the bug, then please post a comment with the version you tested against, and the problem. If the issue is no longer there, please set the RESOLUTION to  RESOLVED, WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Comment 5

8 years ago
Bug still exists.
Test version: Firefox 3.6.10
OS: Windows Vista → Windows 7
Hardware: x86 → x86_64
Version: 3.0 Branch → 3.6 Branch

Updated

8 years ago
Whiteboard: [CLOSEME 2010-11-01]

Comment 6

5 years ago
Reporter, can you still reproduce using a current version?
If no, please set status to RESOLVED and resolution to WORKSFORME.
If yes, please provide updated information.
Whiteboard: [closeme 2013-07-25][FF3.x]

Comment 7

5 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago5 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2013-07-25][FF3.x] → [FF3.x]
You need to log in before you can comment on or make changes to this bug.