selection disappear when style.overflow is changed on the body

RESOLVED DUPLICATE of bug 671055

Status

()

Core
Selection
RESOLVED DUPLICATE of bug 671055
9 years ago
7 years ago

People

(Reporter: François-Xavier Bois, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9

You have a page (P) with an iframe with designMode=on.
The iframe contains text which is selected.
When you change the style.overflow of P.body, the selection inside the iframe disappears.
It is quite annoying when you try to develop a richtext with modal (the modal objet set the overflow to hidden in order to prevent scrolling).

Reproducible: Always

Steps to Reproduce:
1.open the testcase
2.select text inside the iframe
3.click on the link hidden


Actual Results:  
the selection disappears

Expected Results:  
perhaps should not disappear

the selection doesn't disappaer in opera or chrome

Updated

9 years ago
Component: General → Selection
Product: Firefox → Core
QA Contact: general → selection
(Reporter)

Updated

9 years ago
Component: Selection → General
Product: Core → Firefox
Version: unspecified → 3.0 Branch
Component: General → Selection
Product: Firefox → Core
Version: 3.0 Branch → 1.9.0 Branch

Updated

7 years ago
Blocks: 671055
bug 671055 was filed later, but it has an attached testcase. I mark this bug dup of it.
No longer blocks: 671055
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671055
You need to log in before you can comment on or make changes to this bug.