Filter with 'Begins With' does not work

VERIFIED FIXED in M18

Status

P1
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: bugzilla-mozilla-org, Assigned: Bienvenu)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+] Fix in hand.)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-3 i686; en-US; m18) Gecko/20000815
BuildID:    2000081505

If a filter is set to match the beginning of a field (with 'Begins With'), it
will not work.  The same filter with 'Contains' does work.

Reproducible: Always
Steps to Reproduce:
1. Create a filter with 'Subject' 'Begins With' field text 'Test', and any
action (e.g. Delete).
2. Ensure it is enabled.
3. Send a message to yourself matching the filter, e.g. 'Testing e-mail' as the
subject.

Actual Results:  No action is taken; it's as if the rule is being ignored or the
pattern is not matching.

Expected Results:  Should have taken the action defined in the filter rule.
(Assignee)

Comment 1

18 years ago
d'uh, I see the problem. One line fix.
Assignee: alecf → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: nsbeta3
(Assignee)

Comment 2

18 years ago
marking p1 because I have a fix in hand and don't want the priority lowered.
Status: NEW → ASSIGNED
Priority: P3 → P1
Whiteboard: Fix in hand.

Updated

18 years ago
QA Contact: lchiang → laurel

Comment 3

18 years ago
Heh. One of the reasons I was not using seamonkey mail fulltime is that most
of my filters are 'begins with'. I just figured all this time that all filters
were broken, so I continued to use 4.x to get the right folder sorting.
(Now, if only the ability to match on 'x-resent-from', etc. had not been cut).

Comment 4

18 years ago
+ per mail triage
Keywords: mail6
Whiteboard: Fix in hand. → [nsbeta3+] Fix in hand.
Target Milestone: --- → M18
(Assignee)

Comment 5

18 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 6

18 years ago
OK using aug31 commercial build, linux rh6.0, NT 4.0 and mac OS 9.0
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.