If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Get nsDebug:: Assertion after selecting the second message

VERIFIED FIXED

Status

MailNews Core
Backend
P1
blocker
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: fenella, Assigned: Scott MacGregor)

Tracking

({smoketest})

Trunk
x86
Windows NT
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+])

(Reporter)

Description

17 years ago
Win32 (2000-08-15-08 M18)
1. Launch Messenger
2. From my IMAP account, select a message from the Inbox. No problem. I can view
it.
3. Select another message
Actual result: A nsDebug:: Assertion dialog pops up. If I do retry, it crashes.
Expected result: Should be able to view message. Should not crash

This happens in POP account too.

Have not tested Linux and Mac yet.
(Reporter)

Comment 1

17 years ago
I see the same problem when I do delete messages. After the first Delete, it
may  crash on the second or the third one.
Severity: normal → blocker
Priority: P3 → P1
(Assignee)

Comment 2

17 years ago
scott what happend to the bug you filed about this? Can you dup this one with it?
(Reporter)

Comment 3

17 years ago
On Linux (2000-08-15-05 M18)
I see this in the console window when I click on a message

OpenURL from XUL
targetclass = treecell-indent tree-cell-threadpane-icon
stopping meteors 1
q                                                                                                                  
┬▒stopping meteors
mailCharsetLoadListener: ISO-8859-1
[@0x9003d6c] Box inherits='orient' autostretch='never' flex='1' ###!!!
ASSERTION: SetBounds Size < 0: 'aRect.width >=0 && aRect.height >= 0', file
nsBox.cpp, line 532
###!!! Break: at file nsBox.cpp, line 532
mailbox_message://qatest01@nsmail-2/Inbox#144006
 
 
OpenURL from XUL
 
 
stopping meteors 1
Document: Done (4.995secs)
stopping meteors
mailCharsetLoadListener: ISO-8859-1
targetclass = treecell-indent tree-cell-threadpane-icon
targetclass = treecell-indent tree-cell-threadpane-icon
targetclass = treecell-indent tree-cell-threadpane-icon
targetclass = treecell-indent tree-cell-threadpane-icon
mailbox_message://qatest01@nsmail-2/Inbox#146470
 
                                                                 
QA Contact: lchiang → fenella
(Assignee)

Comment 4

17 years ago
this is a blocker..you can't read mail.
Keywords: smoketest

Comment 5

17 years ago
*** Bug 49053 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
other bug was assigned to evaughan.  Fenella, this probably has to do with a 
specific message, not having to do with reading the second message or deleting.  
Keywords: dogfood

Comment 7

17 years ago
I don't think the assertion has anything to do with the crash - I see the
assertion all the time, and I never crash. Again, I don't think this is a
blocker, unless we're saying the assertion is the blocker. If so, this bug
should be assigned to evaughan, I believe, since the assertion is happening in
layout.

Comment 8

17 years ago
If this bug is happening often for daily use (no matter whose bug), I need to 
call it [dogfood+]...If not, please make [dogfood-] and nominate for nsbeta3
Whiteboard: [dogfood+]

Comment 9

17 years ago
This WORKSFORME on Win32 and Linux. Could we get a stack trace or something in
the bug?

Comment 10

17 years ago
I saw this bug as well. Talkback later sent a crash back.
(Assignee)

Comment 11

17 years ago
But an assertion would normally be fine. This is throwing a win nt dialog on
release builds. And QA is crashing when they try to dimiss the dialog.

I've gotten email that 3 separate QA people have already run into this today....
(Assignee)

Comment 12

17 years ago
*** Bug 49078 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
Ok.  I just downloaded today Win32 build 2000-08-15-08 on Win95.  I...

1) rolled up my sleeves (key step here)
2) prayed for 30 minutes with no crash
3) launched Netscape 6
4) opened a Mail window
5) sorted my msgs by subject
6) clicked on the top most mail

AND CRASHED!...with the assertion notification.

Here's the Stack Trace - Talkback Incident ID 15814056 :
Stack Trace

KERNEL32.DLL + 0x670d (0xbff7670d) 
nsBox::SetBounds [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, 
line 535] 
nsBoxFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 775] 
nsLineLayout::ReflowFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineLayout.cpp, line 937] 
nsInlineFrame::ReflowInlineFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsInlineFrame.cpp, line 564] 
nsInlineFrame::ReflowFrames 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsInlineFrame.cpp, line 413] 
nsInlineFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsInlineFrame.cpp, line 329] 
nsLineLayout::ReflowFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineLayout.cpp, line 937] 
nsBlockFrame::ReflowInlineFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 4337] 
nsBlockFrame::DoReflowInlineFrames 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line
4221] 
nsBlockFrame::DoReflowInlineFramesAuto 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line
4157] 
nsBlockFrame::ReflowInlineFrames 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 4103] 
nsBlockFrame::ReflowLine 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3237] 
nsBlockFrame::ReflowDirtyLines 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2926] 
nsBlockFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1730] 
nsBoxToBlockAdaptor::Reflow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxToBlockAdaptor.cpp, line 
816] 
nsBoxToBlockAdaptor::DoLayout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxToBlockAdaptor.cpp, line
486] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 
1002] 
nsBoxToBlockAdaptor::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxToBlockAdaptor.cpp, line
333] 
nsSprocketLayout::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 
1201] 
nsContainerBox::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 448] 
nsBoxFrame::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 853] 
nsSprocketLayout::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 
1201] 
nsContainerBox::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 448] 
nsBoxFrame::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 853] 
nsSprocketLayout::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 
1201] 
nsContainerBox::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 448] 
nsBoxFrame::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 853] 
nsSprocketLayout::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 
1201] 
nsContainerBox::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 448] 
nsBoxFrame::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 853] 
nsSprocketLayout::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 
1201] 
nsContainerBox::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 448] 
nsBoxFrame::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 853] 
nsSprocketLayout::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 
1201] 
nsContainerBox::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 448] 
nsBoxFrame::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 853] 
nsSprocketLayout::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 
1201] 
nsContainerBox::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 448] 
nsBoxFrame::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 853] 
nsSprocketLayout::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 
1201] 
nsContainerBox::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 448] 
nsBoxFrame::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 853] 
nsSprocketLayout::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 
1201] 
nsContainerBox::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 448] 
nsBoxFrame::GetPrefSize 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 853] 
nsSprocketLayout::PopulateBoxSizes 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line
695] 
nsSprocketLayout::Layout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 142] 
nsContainerBox::DoLayout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 555] 
nsBoxFrame::DoLayout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 978] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 
1002] 
nsStackLayout::Layout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsStackLayout.cpp, line 246] 
nsContainerBox::DoLayout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 555] 
nsBoxFrame::DoLayout 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 978] 
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 
1002] 
nsBoxFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 778] 
nsRootBoxFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsRootBoxFrame.cpp, line 211] 
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
716] 
ViewportFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 546] 
nsHTMLReflowCommand::Dispatch 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLReflowCommand.cpp,
line 145] 
PresShell::ProcessReflowCommands 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4239] 
ReflowEvent::HandleEvent 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4128] 
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 588] 
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, 
line 547] 
(Assignee)

Comment 14

17 years ago
I hate to send hyatt yet another blocker bug. I'm worried he's going to start
hating me. But the problem is coming from nsBoxFrame::Reflow. I think he's
covering evaughan's area since eric's on a big vacation....
(Assignee)

Comment 15

17 years ago
gee that stack trace sure looks suspicious....
sprocket get pref size calls box frame::get pref size which calls container
box::get pref size which calls sprocket get pref size. And we repeat that chain
through many iterations before crashing in nsBoxFrame::reflow

Comment 16

17 years ago
using hyatt's account by ftang:
hyatt find the fix, the 1.120 of nsBoxFrame.cpp cause this problem. I ask hyatt 
back out that change and fix it.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 17

17 years ago
I ended up reaching the same conclusion as hyatt. Just a few minutes slower =).
Backing out this fixes the problem for me. 

Comment 18

17 years ago
I have added my fixes back in (version 1.120) and I can't reproduce the 
assert/crash with a build from last night (Tues night) using a POP account. 
Sera is down so I can't try IMAP at the moment.

Was there some particular type of e-mail message that made it assert/crash? I 
would like to try to figure out how to still fix 40956 and not break mail.

Comment 19

17 years ago
*** Bug 49176 has been marked as a duplicate of this bug. ***

Comment 20

17 years ago
*** Bug 49183 has been marked as a duplicate of this bug. ***

Comment 21

17 years ago
rods - you asked for a specific mail msg which would cause the assert.  Bug 
http://bugzilla.mozilla.org/show_bug.cgi?id=49053 (dupe) has a simple message 
attached by kin which causes the assert.

Comment 22

17 years ago
*** Bug 49191 has been marked as a duplicate of this bug. ***

Comment 23

17 years ago
I was able to get it to assert and the issue was a box frame getting an 
available width with a negative number. I have a fix for my original bug.
(Reporter)

Comment 24

17 years ago
Linux (2000-08-16-09 M18)
Win32 (2000-08-16-10 M18)
Mac (2000-08-16-10 M18)
Verified that this problem is fixed.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.