Regular Expression search hangs Firefox

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: vijay2345, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

Steps:
1: Go to this URL http://www.csharp-station.com/Tutorials/AdoDotNet/Lesson02.aspx

2: Ctrl+F, select Regualr Expression check box

3:Enter "^" then "\", brozer frozen....

Note: I was trying to enter search text "^\//" to find all lines starting with "\\"

Thanks,
Vijay

Reproducible: Always

Updated

10 years ago
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Vijay, are you running some add-on that adds a regular expression check box? I don't have one in any version of Mac FF.
(Reporter)

Comment 2

10 years ago
Oh my god!! I am extremely sorry for false alarm!! 
My FF gets regular expression search option through an add-on called /Find Bar/ 1.0.1
No problem. I'm going to mark it invalid for now. If the Find Bar maintainers determine that it's caused by a JS engine bug, we can reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.