Wrong image and icon colors in Fx 3.5b4

RESOLVED DUPLICATE of bug 490537

Status

()

Core
GFX: Color Management
--
major
RESOLVED DUPLICATE of bug 490537
9 years ago
9 years ago

People

(Reporter: initzero, Unassigned)

Tracking

1.9.1 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b4) Gecko/20090428 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b4) Gecko/20090428 Firefox/3.5b4

Some images (saw it happen with JPEG and PNG) and icons have very strange colors.

Reproducible: Always

Steps to Reproduce:
1. Occurs somewhere on almost every webpage
Actual Results:  
Wrong colors

Expected Results:  
Proper colors

Test system: Ubuntu 9.04 AMD64, xorg-server 1.6 with ATI fglrx 9.4 driver, 64bit Fx.

Fx 3.0.x _not_ affected
(Reporter)

Comment 1

9 years ago
Created attachment 375037 [details]
Example screenshot
(Reporter)

Updated

9 years ago
Summary: Wrong images and icon colors in Fx 3.5b4 → Wrong image and icon colors in Fx 3.5b4
Version: unspecified → 3.5 Branch
>Fx 3.0.x _not_ affected
Please open Firefox 3.0.X, enter about:config, confirm the warning, enter GFX in the top search bar and set gfx.color_management.enabled to true. (default=false).

Now test one of your strange images and is Firefox3.0.X affected or not ?
(Reporter)

Comment 3

9 years ago
Firefox 3.0.X with gfx.color_management.enabled = true is also affected.
Somehow you have a wrong Color profile enabled on your system.
Color Managemenet is enabled for images with color information by default in Firefox3.5. That's the reason why you get this in FF3.5beta4.
read bug 490537#c8 for the changed preference in Firefox3.5

This could be a dupe of bug 490537
Component: General → GFX: Color Management
Depends on: 490537
Product: Firefox → Core
QA Contact: general → color-management
Version: 3.5 Branch → 1.9.1 Branch
(Reporter)

Comment 5

9 years ago
Alright, thanks for your help!

> This could be a dupe of bug 490537
Agree.
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 490537

Updated

9 years ago
No longer depends on: 490537
You need to log in before you can comment on or make changes to this bug.