If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Save to" window loses focus when downloading file caused by [ESET NOD32]

RESOLVED INCOMPLETE

Status

()

Firefox
Extension Compatibility
RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: cguest2, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-09-15], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10

When downloading a file, after clicking the "Save File" button the "Save to..." window will appear for a brief period and then disappear behind the browser window (losing focus)

Reproducible: Always

Steps to Reproduce:
1. In Firefox click on Tools > Options > Main tab > Select radio button "Always ask me where to save files" > Click OK

2. Navigate to a website which has a link to download a file like http://www.rarlab.com/download.htm

3. Click on the link "WinRAR 3.80" and choose "Save File"

4. You should see the "Save to" window pop up briefly before disappearing.

5. Click anywhere on the Firefox window and "Save to" window will reappear and then function as normal.
Actual Results:  
See steps for actual results ^

Expected Results:  
After clicking the "Save As" button the "Save to" window should appear and remain in focus (not requiring the user to click on the Firefox window for it to appear)

I have been able to recreate this issue on three separate Windows XP machines.
(Reporter)

Updated

9 years ago
Summary: Save to window loses focus when downloading file → "Save to" window loses focus when downloading file
Not a shell integration bug... likely a widget or download manager bug.
Component: Shell Integration → Download Manager
Product: Firefox → Toolkit
QA Contact: shell.integration → download.manager
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11pre) Gecko/2009042905 GranParadiso/3.0.11pre

This works fine for me; the filepicker has focus when it appears.
Do you get the same result in safe-mode? And if so, can you reproduce the problem if you create a new profile?

http://support.mozilla.com/en-US/kb/Safe+Mode
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Version: unspecified → 1.9.0 Branch
(Reporter)

Comment 3

9 years ago
I get the same result when I start Firefox in Safe-Mode, and also when I create a new Firefox profile.

However, if I boot XP in safe-mode with networking it seems to be fine.

Are there any known services that conflict with Firefox that I could try disabling?
Do you still see this problem using the newest versions of Firefox (3.6)?

If you do not, please close the bug with resolution set to WORKSFORME (after staus=RESOLVED). If problem was caused by add-on or non-mozilla code please use INVALID resolution.
If you do still see the problem, please comment in the bug.
Whiteboard: [closeme 2010-09-15]
(Reporter)

Comment 5

7 years ago
I still have the problem in Firefox 3.6.8

I have determined the conflicting program as ESET NOD32 Antivirus 4
When I disable the anti-virus I do not see the problem in Firefox, but as soon as I re-enable the software it comes back.  This is also the case if I run Firefox in safe mode.

NOD32 appears to not like how the filepicker is changing focus over the main browsing window and keeps it hidden in the background until I click the browser window and it reappears.

I checked IE8 and it does not have this problem

Comment 6

7 years ago
Report this issue to ESET then. There is not anything we can do in the stock Firefox. Moving to extension compatibility for tracking.
Component: Download Manager → Extension Compatibility
Product: Toolkit → Firefox
QA Contact: download.manager → extension.compatibility
Version: 1.9.0 Branch → 3.6 Branch

Updated

7 years ago
Summary: "Save to" window loses focus when downloading file → "Save to" window loses focus when downloading file caused by [ESET NOD32]
No reply, INCOMPLETE. Please retest with Firefox 3.6.10 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.