Possible to copy built-in Places nodes into themselves in the Bookmarks sidebar

RESOLVED DUPLICATE of bug 432368

Status

()

RESOLVED DUPLICATE of bug 432368
10 years ago
9 years ago

People

(Reporter: smrank, Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

It's possible to accidentally (or deliberately) copy one of the built-in nodes such as Bookmarks Menu or Unsorted Bookmarks into itself (or one of the other nodes).

Reproducible: Always

Steps to Reproduce:
1. Open Bookmarks Sidebar (Ctrl-B).
2. Open the Unsorted Bookmarks section (if it is empty, add a bookmark to it first).
3. Drag the Unsorted Bookmarks section into itself.

Actual Results:  
The drag succeeds and makes a copy of the node and all its bookmarks inside itself, if a lot of bookmarks are present it causes an unresponsive script warning.

Expected Results:  
The drag should not be allowed.

When I tried copying my Bookmarks Menu into itself I must have clicked through 5 or 6 unresponsive script warnings before deciding to kill Firefox, when I restarted it had copied about a third of my bookmarks.

p.s. This is hard thing to search for so I hope it isn't a duplicate.
Flags: blocking-firefox3.5?
Keywords: regression, regressionwindow-wanted
Version: unspecified → 3.5 Branch
Sorry I had assumed this was a regression, which it is not.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Same behavior.
Flags: blocking-firefox3.5?
Keywords: regression, regressionwindow-wanted
...and this is a dupe.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 432368
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.