Closed Bug 49066 Opened 24 years ago Closed 24 years ago

Crash starting up mail when we try to bring up the password dialog

Categories

(Core :: XBL, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: mscott, Assigned: saari)

References

Details

(Keywords: crash, smoketest, Whiteboard: [dogfood+])

heh, sorry to keep giving you these bugs Dave. But I haven't been able to get 
mail to run in my debug build since the weekend. 

Now I'm crashing after we bring up the mail 3-pane when we should be loading the 
password dialog. This is with a build pulled around midnight last night.

The XBLEventhandler is firing an event that's causing us to crash QI'ing a bogus 
xul element:

nsXULElement::QueryInterface(nsXULElement * const 0x0430fce0, const nsID & 
{...}, void * * 0x0003302c) line 530
nsQueryInterface::operator()(const nsID & {...}, void * * 0x0003302c) line 32 + 
25 bytes
nsCOMPtr<nsIXMLContent>::assign_from_helper(const nsCOMPtr_helper & {...}, const 
nsID & {...}) line 856 + 18 bytes
nsCOMPtr<nsIXMLContent>::nsCOMPtr<nsIXMLContent>(const nsQueryInterface & {...}) 
line 565
nsStyleUtil::IsSimpleXlink(nsIContent * 0x0430fce0, nsIPresContext * 0x03970070, 
nsLinkState * 0x00033238) line 560
SelectorMatches(nsIPresContext * 0x03970070, nsCSSSelector * 0x0142377c, 
nsIContent * 0x0430fce0, int 1) line 3032 + 56 bytes
ContentEnumFunc(nsICSSStyleRule * 0x01423770, void * 0x000333c8) line 3162 + 24 
bytes
RuleHash::EnumerateAllRules(nsIAtom * 0x01402fd0 {"textfield"}, nsIAtom * 
0x04396640 {"dialog.password1"}, const nsVoidArray & {...}, void 
(nsICSSStyleRule *, void *)* 0x01fb06c0 ContentEnumFunc(nsICSSStyleRule *, void 
*), void * 0x000333c8) line 302 + 22 bytes
CSSRuleProcessor::RulesMatching(CSSRuleProcessor * const 0x04321eb0, 
nsIPresContext * 0x03970070, nsIAtom * 0x013f9f40 {"screen"}, nsIContent * 
0x0430fce0, nsIStyleContext * 0x04343210, nsISupportsArray * 0x044132d0) line 
3231
EnumRulesMatching(nsISupports * 0x04321eb0, void * 0x000334a0) line 742
nsSupportsArray::EnumerateForwards(nsSupportsArray * const 0x043213b0, int 
(nsISupports *, void *)* 0x01e4b070 EnumRulesMatching(nsISupports *, void *), 
void * 0x000334a0) line 357 + 20 bytes
StyleSetImpl::WalkRuleProcessors(int (nsISupports *, void *)* 0x01e4b070 
EnumRulesMatching(nsISupports *, void *), void * 0x000334a0, nsIContent * 
0x0430fce0) line 2008
StyleSetImpl::ResolveStyleFor(nsIPresContext * 0x03970070, nsIContent * 
0x0430fce0, nsIStyleContext * 0x04343210, int 0) line 844
nsPresContext::ResolveStyleContextFor(nsPresContext * const 0x03970070, 
nsIContent * 0x0430fce0, nsIStyleContext * 0x04343210, int 0, nsIStyleContext * 
* 0x000335f0) line 502 + 38 bytes
FrameManager::ReResolveStyleContext(nsIPresContext * 0x03970070, nsIFrame * 
0x03a5c200, nsIStyleContext * 0x04343210, nsIContent * 0x00000000, int 0, 
nsIAtom * 0x0139f810 {"focused"}, nsStyleChangeList & {...}, int 2, int & 
210504) line 1279
FrameManager::ComputeStyleChangeFor(FrameManager * const 0x03972fc0, 
nsIPresContext * 0x03970070, nsIFrame * 0x03a5c200, int 0, nsIAtom * 0x0139f810 
{"focused"}, nsStyleChangeList & {...}, int 2, int & 0) line 1457
nsCSSFrameConstructor::AttributeChanged(nsCSSFrameConstructor * const 
0x03970420, nsIPresContext * 0x03970070, nsIContent * 0x0430fce0, int 0, nsIAtom 
* 0x0139f810 {"focused"}, int 2) line 9895
StyleSetImpl::AttributeChanged(StyleSetImpl * const 0x03970480, nsIPresContext * 
0x03970070, nsIContent * 0x0430fce0, int 0, nsIAtom * 0x0139f810 {"focused"}, 
int -1) line 1195
PresShell::AttributeChanged(PresShell * const 0x03970c38, nsIDocument * 
0x042573c0, nsIContent * 0x0430fce0, int 0, nsIAtom * 0x0139f810 {"focused"}, 
int -1) line 3401 + 57 bytes
nsXULDocument::AttributeChanged(nsXULDocument * const 0x042573c0, nsIContent * 
0x0430fce0, int 0, nsIAtom * 0x0139f810 {"focused"}, int -1) line 1647
nsXULElement::UnsetAttribute(nsXULElement * const 0x0430fce0, int 0, nsIAtom * 
0x0139f810 {"focused"}, int 1) line 3043
nsXULElement::RemoveAttribute(nsXULElement * const 0x0430fcec, const nsString & 
{"focused"}) line 1263 + 29 bytes
ElementRemoveAttribute(JSContext * 0x041f2410, JSObject * 0x03a02438, unsigned 
int 1, long * 0x03a5b76c, long * 0x00033fa4) line 280 + 19 bytes
js_Invoke(JSContext * 0x041f2410, unsigned int 1, unsigned int 0) line 716 + 23 
bytes
js_Interpret(JSContext * 0x041f2410, long * 0x000348e0) line 2517 + 15 bytes
js_Invoke(JSContext * 0x041f2410, unsigned int 1, unsigned int 2) line 732 + 13 
bytes
js_InternalInvoke(JSContext * 0x041f2410, JSObject * 0x03a02438, long 61004632, 
unsigned int 0, unsigned int 1, long * 0x00034a74, long * 0x00034a04) line 805 + 
19 bytes
JS_CallFunctionValue(JSContext * 0x041f2410, JSObject * 0x03a02438, long 
61004632, unsigned int 1, long * 0x00034a74, long * 0x00034a04) line 2817 + 31 
bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x041f1780, void * 0x03a02438, 
void * 0x03a2db58, unsigned int 1, void * 0x00034a74, int * 0x00034a70, int 0) 
line 847 + 33 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x044122b4) line 154 + 64 bytes
nsXBLEventHandler::ExecuteHandler(nsXBLEventHandler * const 0x04360920, const 
nsString & {"blur"}, nsIDOMEvent * 0x044122b4) line 688
nsXBLEventHandler::Blur(nsIDOMEvent * 0x044122b4) line 288 + 44 bytes
nsEventListenerManager::HandleEvent(nsIPresContext * 0x03970070, nsEvent * 
0x00035814, nsIDOMEvent * * 0x000353ec, nsIDOMEventTarget * 0x0430fcf0, unsigned 
int 2, nsEventStatus * 0x00035838) line 1176 + 23 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x0430fce0, nsIPresContext * 
0x03970070, nsEvent * 0x00035814, nsIDOMEvent * * 0x000353ec, unsigned int 2, 
nsEventStatus * 0x00035838) line 3298
nsXULElement::HandleDOMEvent(nsXULElement * const 0x04363740, nsIPresContext * 
0x03970070, nsEvent * 0x00035814, nsIDOMEvent * * 0x000353ec, unsigned int 2, 
nsEventStatus * 0x00035838) line 3306 + 39 bytes
nsGenericElement::HandleDOMEvent(nsIPresContext * 0x03970070, nsEvent * 
0x00035814, nsIDOMEvent * * 0x000353ec, unsigned int 1, nsEventStatus * 
0x00035838) line 1446 + 39 bytes
nsHTMLInputElement::HandleDOMEvent(nsHTMLInputElement * const 0x04362f0c, 
nsIPresContext * 0x03970070, nsEvent * 0x00035814, nsIDOMEvent * * 0x00000000, 
unsigned int 1, nsEventStatus * 0x00035838) line 871 + 31 bytes
nsEventStateManager::SendFocusBlur(nsEventStateManager * const 0x04393f00, 
nsIPresContext * 0x03970070, nsIContent * 0x04362f0c) line 2522
nsEventStateManager::SetContentState(nsEventStateManager * const 0x04393f08, 
nsIContent * 0x04362f0c, int 2) line 2375
nsHTMLInputElement::SetFocus(nsHTMLInputElement * const 0x04362f0c, 
nsIPresContext * 0x03970070) line 637
nsHTMLInputElement::Focus(nsHTMLInputElement * const 0x04362f00) line 615 + 28 
bytes
HTMLInputElementFocus(JSContext * 0x041f2410, JSObject * 0x03a025d0, unsigned 
int 0, long * 0x03a5b744, long * 0x00035aa0) line 812 + 15 bytes
I can't read mail because I keep crashing here before I can enter the password. 
Marking as a blocker.
Severity: normal → blocker
Keywords: nsbeta3, smoketest
Hyatt, I see this stop when in the debugger... it is timing related

Something has changed with input elements and focus/blur.  Something bad... :)
Assignee: hyatt → saari
hmm, I was seeing this yesterday, but I did a clobber build in layout and it 
went away.
so much for that, the problem does still occur. I swear it did go away at some
point yesterday because I was blocked on it, then it went away, and I was able
to do some work.
Whiteboard: [dogfood+]
Putting on [dogfood+] radar.
mscott, I thought this had to do with your XUL cache not being on. If so, could
you please clear the blocker & dogfood+ designations? If not, are you the right
person to own the bug?
ah frig, ignore my previous comment. wrong bug.
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
fixed
*** Bug 49073 has been marked as a duplicate of this bug. ***
*** Bug 49071 has been marked as a duplicate of this bug. ***
Adding crash keyword for fix and/or verification escalation
Keywords: crash
verified fixed mac/linux/win32 20000816nn -- multiple logins to each platform
without crashing on the dialog for the password.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.