Memory leak on MSDN site

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: sfairat13, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10

Memory leak,which happens on MSDN site.Firefox consumes memory continiously, and memory isn't released even after the tab with MSDN is closed.After several hours of work with 3 opened MSDN tabs Firefox used over 1GB of real memory and equal amount of virtual memory.It also had 15-20% CP usage.

Reproducible: Always

Steps to Reproduce:
1.Go to MSDN site.Several tabs are required for better effect.
2.Enjoy!)
(Reporter)

Comment 1

9 years ago
Created attachment 375062 [details]
Example of memory usage
(Reporter)

Updated

9 years ago
Summary: Memory leak → Memory leak on MSDN site
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11pre) Gecko/2009042905 GranParadiso/3.0.11pre

The site doesn't seem to do much here with memory usage.
Can you test if it also happens in safe-mode? For it might be caused by a leaking add-on. http://support.mozilla.com/en-US/kb/Safe+Mode
Version: unspecified → 3.0 Branch
(Reporter)

Comment 3

9 years ago
I tested it in safe mode(I disabled all the plugins/themes),I ran five tabs of msdn only and waited for six hours.Firefox used 462 MB of real and 455 MB of virtual memory,compared to ~100 MB at the begining.
I did some experiments on this in Windows. Using the URL http://msdn.microsoft.com/en-us/library/ms644992%28VS.85%29.aspx and a clean profile (only addon is that Sun Java one you can't get rid of). I opened that URL in one tab and about:buildconfig in another tab and nothing else and then minimized the window and didn't touch it except for accidentally activating the window and then minimizing it again immediately. I recorded the Mem Usage and VM size columns from Windows Task Manager. The interval between each measurement was sporadic, sometimes being < 1 hour, other times 10 hours+, and I didn't record a new measurement if the numbers were the same. The total time observed for each build was not consistent but I think was long enough to see what is going on. I used Firefox 3.0.11, a 1.9.1 nightly from around June 16, and the June 17 1.9.2 nightly.

Here are the results. First number is the Mem Usage, second number is the VM size, both are in MB.

3.0.11
------
48 37
59 48
62 50
67 56
71 59
73 62
80 68
86 74
92 81
98 86
202 191

1.9.1 nightly around June 16
----------------------------
45 38
55 48
100 92
109 102
110 103
112 105
114 107
122 115

1.9.2 nightly June 17
---------------------
40 34
54 48
58 51
59 53
60 53
62 55
61 54
61 54
60 53
61 54
62 54
62 55

I made sure to observe the 1.9.2 nightly for longer than the other two.

So whatever the problem is it seems to be fixed in mozilla-central. Any idea what might have fixed this?

Comment 5

9 years ago
I confirm that the problem exists.

The leakage occures after some MSDN tabs are opened. Memory consumption when three tabs are open increases for about 1MB a minute. If I'm surfing normally I have about 30-40 tabs with MSDN articles - the memory footprint gains 1600-1700 MB for about 1-1.5 hours.

After that Firefox becomes unusable - the CPU load is about 50% (on dual core system) and does not react on user actions.

System info: Intel C2Duo 2160 / 3GB RAM / Windows 2003 SP2 / Firefox 3.5.2 Release

The sample links which lead to leakage:

http://msdn.microsoft.com/en-us/library/system.io.stringwriter_members(VS.80).aspx
http://msdn.microsoft.com/en-us/library/system.io.stringwriter_members(VS.80).aspx
http://msdn.microsoft.com/en-us/library/aa480242.aspx
Alex, could you try a current nightly build to see if the issue is fixed there? I tried Firefox 3.5 and still had the issue, but with a mozilla-central (what will become the next version of Firefox) nightly I found the problem was no longer there. You can get the latest mozilla-central nightly at ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/ (find your platform there). Don't install (or uncompress) it over your current installation and use a fresh new profile to avoid damaging your profile (see http://support.mozilla.com/en-US/kb/Managing+profiles for help with profile stuff). Thanks!

Comment 7

9 years ago
I have just tried the nightly build from nightly/latest-mozilla-central-l10n/firefox-3.7a1pre.ru.win32.zip (1 Sept 2009). 

The problem is still there but the memory consumption grows more slowly. With the clean run (no extensions, no tabs open but MSDN) it gains 100KBytes a minute for three tabs and at average 1.3MByte a minute for 15 tabs.

The performance improvement is really great in alpha. 

I hope this information helps. Wonder what is a cause for this leakage - the badly designed javascript on the pages?
If you leave it running longer, does it eventually level out (with a mozilla-central build)? That's what seemed to happen for me, I did my test over probably 24 hours or more to be sure it didn't go up anymore.

Comment 9

9 years ago
Ok, I'll try it. But I have to run it on a different hardware but my working PC.
You can run two separate copies of Firefox with different profiles on the same computer at the same time by using the -no-remote command line argument. http://kb.mozillazine.org/Opening_a_new_instance_of_your_Mozilla_application_with_another_profile

Comment 11

8 years ago
please see Bug 516202 comment 9
- Memory use grows steadily while MSDN pages are open, leading to OOM crash after a few days idle
This is a mass search for Firefox General bugs filed against version 3.0 that are UNCO and have not been changed for 200 days.

Reporter, please update to Firefox 3.6.10 or alter. Firefox 3.0 is no longer supported and is no longer receiving updates. After you update, please create a fresh profile, http://support.mozilla.com/kb/managing+profiles, and test to see if your bug still exists. If you still the bug, then please post a comment with the version you tested against, and the problem. If the issue is no longer there, please set the RESOLUTION to  RESOLVED, WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Updated

8 years ago
Version: 3.0 Branch → 3.6 Branch

Updated

8 years ago
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Comment 13

8 years ago
I've run FF 3.6.11 with nearly 20 tabs, and the memory consumption after six hours was the same, as at the beginning, so it seems that the bug is resolved now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: [CLOSEME 2010-11-01]
You need to log in before you can comment on or make changes to this bug.