please QA the Fastest Firefox phase 1 page

VERIFIED FIXED in 3.5

Status

www.mozilla.org
General
--
critical
VERIFIED FIXED
9 years ago
6 years ago

People

(Reporter: John Slater, Assigned: stephend)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

9 years ago
Hey guys. This is the first of three pages for our Fastest Firefox campaign. It's related to 3.5, but will actually be launching about 3 weeks before the release so there's a bit more urgency there (I'm also hoping to have this localized into at least a few languages, but that's still TBD).

Stephen, I'll put together that long-promised project wiki today.

A few notes & known issues:
1. The main illustration (with the gopher) will be replaced with a project-specific one soon.
2. The video is a place-holder for now (will update it with the correct one shortly before launch).
3. The upload due date is a placeholder as well (will update that when we have a more solid 3.5 release date)
4. The "Upload Your Video" link is dead, because the Upload page isn't setup yet (Alex has Steven's layout and is working on it).

Thanks!

Comment 1

9 years ago
Steps to reproduce:
1.Go to https://www-trunk.stage.mozilla.com/en-US/firefox/features/
2.Do a mouse hover on "fastest firefox" link in the side nav bar
3.Click on "Videos" link 
4.Repeat step #2


expected result:
On step 2,there is a pointing hand on "fastest firefox" link,indicating that its click-able.

actual result:

-No pointing hand on step #2
-Pointing hand on doing a mouse hover from any other page like/videos or/performance

Browsers:

-Shiretoko  version:Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090422 Shiretoko/3.5b4pre

-Safari 3.2.2

Additional info:

works fine in IE8
(Assignee)

Updated

9 years ago
Assignee: nobody → stephen.donner
(Assignee)

Comment 2

9 years ago
Created attachment 375148 [details]
Screenshot showing "Fastest Firefox" blending in with the white background
(Assignee)

Comment 3

9 years ago
"Sunspider" should read "SunSpider".
Link issue from #1 fixed in rr25106.

(In reply to comment #2)
> Screenshot showing "Fastest Firefox" blending in with the white background
Fixed in r25107.



(In reply to comment #3)
> "Sunspider" should read "SunSpider".
Fixed in r25109.
1/ the upload video button image shouldn't have the text hardcoded in it
https://www-trunk.stage.mozilla.com/img/tignish/firefox/fastest/upload.png

2/ javascript should not be mixed with html but seperated in an external file

3/ preview coming image shouldn't have text hardcoded
https://www-trunk.stage.mozilla.com/img/tignish/firefox/fastest/preview-coming-soon.jpg

4/ unnecessary paragraph tags in lists
<ol>
 <li><p>

5/ we use video, we should have the $html5 = true; variable to trigger an HTML5 DTD
(Reporter)

Comment 7

9 years ago
I'm not one to comment on code, but Pascal's suggestions in comment #6 seem good to me.

Updated

9 years ago
Blocks: 488139
(In reply to comment #6)
Issues 1, 3, & 4 addressed in r25167.

Issue 5 addressed in 25169.
(In reply to comment #6)
> 2/ javascript should not be mixed with html but seperated in an external file

Pascal, this JS really just defines which videos are loadable on the page, including the URL and title of each video, which is locale-specific.
ok, good catch, I didn't notice the title, let's keep that then
(Assignee)

Comment 11

9 years ago
John - didn't see a separate bug for the upload functionality being implemented by Alex; will there be one filed, or did you want to do that work here?
(Reporter)

Comment 12

9 years ago
(In reply to comment #11)
> John - didn't see a separate bug for the upload functionality being implemented
> by Alex; will there be one filed, or did you want to do that work here?
I'll file a separate bug once the upload page is ready...I've been told that it'll be soon, so keep an eye out!
(Assignee)

Comment 13

9 years ago
AFAIC, this is ready to begin the localization process -- marking fixed, since we will have a bug for the videos themselves (comment 12, above).
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 14

9 years ago
Created attachment 375878 [details]
IE 6 button-layout bug
(In reply to comment #14)
> Created an attachment (id=375878) [details]
> IE 6 button-layout bug

Fixed in r25332.
(Assignee)

Comment 16

9 years ago
Created attachment 376439 [details]
Screenshot of new layout regression using the latest 1.9.1 nightly
(In reply to comment #16)
> Screenshot of new layout regression using the latest 1.9.1 nightly

Fixed in r25268.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
(Assignee)

Comment 18

9 years ago
Reopening: this page needs to link to the Upload page.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #18)
> Reopening: this page needs to link to the Upload page.

Added link in r25773. The link isn't actually live yet, though.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Update: the real video is actually in place and ready for testing. The password required for the video is available on https://bugzilla.mozilla.org/show_bug.cgi?id=494309
(Assignee)

Updated

9 years ago
Severity: normal → critical
(Assignee)

Comment 21

9 years ago
(In reply to comment #20)
> Update: the real video is actually in place and ready for testing. The password
> required for the video is available on
> https://bugzilla.mozilla.org/show_bug.cgi?id=494309

Please cc me?  I can't see it :-(  Thanks!
Reopening for questions I asked in the upload bug instead of this one:

A few question:

1/

The videos have urls pointing to different folders:
/1/fastest-clapper.mp4
/4/fastest-clapper.ogg

Is it normal that these 2 videos are not in the same folder?

2/
There is a close button on the video player that is hardcoded in English in the
source javascript file which is bad:

Mozilla.VideoScaler.close_text = 'Close';
[...]
document.createTextNode(
 Mozilla.VideoScaler.close_text
)

I am putting it for localization as a php variable in the file given to
localizer, the javascript function using it has to be modified to use this
variable and not a constant

3/ the launch date is not defined and left as a placeholder, if we don't know
the launch date, we can't translate the sentence with the date in it. The only
solution I see is to put it as a variable and display it in numeric form for
locales like:
$launch_date = strftime(___('%Y-%m-%d'), strtotime('2009-06-01')); 

Then instead of putting "Follow the steps below and upload by June 1, 2009."
put "Follow the steps below and upload before this date: 06-01-2009" for
locales.

4/ there is a commented out javascript file include in the footer, should be
removed.

5/ there are placeholders for 2 future videos, so it means that there is
maintenance work for localizers that will have to update the files with new
video descriptions over time, when will these updates be required? I need to
communicate these dates to localizers so as to pick locales that are able to do
the initial localization *and* update the file when new text is added.

6/ one more thing, there is a download block for 3.5 beta in a sidebar, by the
time this page goes public, Firefox 3.5RC1 should have been already released.


7/ "Pascal, this JS really just defines which videos are loadable on the page,
including the URL and title of each video, which is locale-specific."

How/Why are the URLs locale-specific? Does that mean that we will put different videos depending on the language of the page?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 23

9 years ago
Re: comment #22...

Pascal, thanks for jumping in here. I think the l10n will really help the overall success of this project quite a bit.

Most of these comments are probably better answered by Steven...Steven, can you take a look at these in the morning? Pascal said he could get l10n started tomorrow if we can get these questions answered/resolved by noonish Pacific time.

Point #3:
The tricky part is that we don't know when the release date is yet, so I've been hesitating to define this. For example, I want to make videos due by 6/21, but if the release slips a few weeks then we lose a bunch of time. So, if you're ok with that variable date thing let's do that. Here's my suggested text:
"Follow the steps below and update before XX-XX-2009."

Point #5:
Again, the dates could shift around if the release slips but right now it's looking like we'll launch the 1st video on June 1, the 2nd video on June 8 and the 3rd video on June 15. But, we also have all the descriptive text written for the other videos...if I send it to you could the localizers do it all now (if that's easier)?

Point #6:
I think we'll be ok for the June 1 launch, b/c my understanding is that RC1 will be shortly after that. But, you're right about afterwards. What do you recommend? Would it be better to change the text to something more vague, like "Download a pre-release version of Firefox 3.5"?

Pascal, let me know what you think about this stuff. Steven, any answers you can provide about the technical side of things would be great.

Thanks all!!
"Again, the dates could shift around if the release slips but right now it's
looking like we'll launch the 1st video on June 1, the 2nd video on June 8 and
the 3rd video on June 15. But, we also have all the descriptive text written
for the other videos...if I send it to you could the localizers do it all now
(if that's easier)?"

definitely!!
(Reporter)

Comment 25

9 years ago
(In reply to comment #24)
> "Again, the dates could shift around if the release slips but right now it's
> looking like we'll launch the 1st video on June 1, the 2nd video on June 8 and
> the 3rd video on June 15. But, we also have all the descriptive text written
> for the other videos...if I send it to you could the localizers do it all now
> (if that's easier)?"
> 
> definitely!!
Ok, here's the text for the second and third videos (with links):

Watch Steven Purugganan's video as the world's Fastest Sport Stacker.

Fellow Guinness World Record Holder, Steven Purugganan loves Firefox enough to do some fast cup stacking, just for us. As part of the World Sport Stacking Association, Steven is only 11 years old, but his fast hands put a pile of cups in their place in only 5.93 seconds. 
_Learn more about Sport Stacking._
[link: http://worldsportstackingassociation.org]

Watch Todd Taylor's video as the world's Fastest Banjo Player

Banjoman Todd Taylor is happy to play fast for Firefox—and to call himself a fellow Guinness World Record Holder. Todd has played bluegrass, country, pop and rock & roll. He continues to record and play in movies, TV and more. 
_Learn more about Todd._
[link: www.toddtaylorbanjoman.com]

[Steven, one note for you: I actually changed Todd Taylor's bio text a slight bit...not sure when the best time to update the en-US file is, but fyi]
I need to see the final html for this page once the three videos are online so as to construct something not requiring me to reedit the files in the future for localization, Steven can you attach it here ? thanks
Made the changes to the date phrasing and download link. More to come.
2/ I've added the 'Close' text to the page source for translators in r26470.
Created attachment 380239 [details]
HTML File with all three video desc for pascal

Here's the HTML file with all three video titles/desc in place for Pascal.
Created attachment 380242 [details]
Updated HTML file

Updated version of the HTML file for pascal with a few fixes.
Attachment #380239 - Attachment is obsolete: true

Updated

9 years ago
Attachment #380242 - Attachment mime type: text/html → text/plain
(Reporter)

Comment 31

9 years ago
Hey guys. Two things here:

1. Most importantly, the video player isn't working for me. When I click on it, the lightbox appears with a grey X in it rather than the video itself.

2. Let's go ahead and change the submission deadline to 6-21-09 (or 21-6-09 depending on where you are).

Not sure what's going on with the video player...can we get it fixed ASAP?

Thanks!
J
I just tried and the video works for me
(Reporter)

Comment 33

9 years ago
(In reply to comment #32)
> I just tried and the video works for me
It's working for me now, too. Donner and I checked it out and decided it was a password thing. Still, something to double check before we go live on Monday.

Point 2 from comment #31 still stands, though!
for localized versions the date is now updated
The date is added to the en-US version in r26616.

Updated

9 years ago
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
verified fixed on https://www.mozilla.com/en-US/firefox/fastest/
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.