Maximum numbers of Concurrent download

RESOLVED DUPLICATE of bug 648603

Status

()

Core
Networking: HTTP
RESOLVED DUPLICATE of bug 648603
9 years ago
6 years ago

People

(Reporter: gumgum, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)

It seems that the maxium numbers of concurrent download limited at 8. When there are 8 concurrent download FF cannot perform additional download nor connect to a www page.

Reproducible: Always

Steps to Reproduce:
1. create 8 concurrent download.
2. try to connect to a www page or do a new download.
3.
Actual Results:  
FF is waiting.

Updated

9 years ago
Component: General → Networking: HTTP
Product: Firefox → Core
QA Contact: general → networking.http

Comment 1

9 years ago
There are settings that limit the maximum number of connections, to protect the webserver, the proxyserver, the network and the webbrowser in itself. Similar settings have existed since Netscape 1.0. Even Internet Explorer has them.

https://developer.mozilla.org/en/Mozilla_Networking_Preferences

In your case, I think you're using a proxy server, since the network.http.max-persistent-connections-per-proxy is 8. You can see more settings (and change them), by typing about:config in the location bar, and filtering on network.http. The defaults ones in 3.5 have been enlarged compared to 3.0, if you compare them with the text above.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 648603
You need to log in before you can comment on or make changes to this bug.