Possible layout bug -- some text not rendering at all

RESOLVED WONTFIX

Status

()

Core
HTML: Parser
P3
normal
RESOLVED WONTFIX
18 years ago
17 years ago

People

(Reporter: Paul Roub, Assigned: rickg)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Strict DTD Invalid Page], URL)

(Reporter)

Description

18 years ago
(8/15 Nightly build)

Not 100% sure this isn't a bad-HTML bug, but I don't see anything in the source 
that should cause this problem.  Text displays fine in IE5.5, NN 4.7, Amaya, 
Opera.  The problem is present both in M17 and the 8/15 nightly build.

The Spamcop home page contains a list of rules, followed by an "I Understand 
and agree link", written like so:

...


<ol>
<strong>READ THIS</strong>
<li>If I break these rules, my access to SpamCop will be immediately revoked.
<li>I will use SpamCop only on email which is unsolicited, bulk email.
  <a href="/fom-serve/cache/125.html">(more..)</a>
<li>I understand SpamCop uses my email address to send email to administrators.
<li>Administrators will respond to this email both in person and automatically.
 I understand these replies are not spam.
<li>I take full responsibility and assume all liability for email I send
 using SpamCop.
</ol>

<a href="anonsignup.shtml"><strong>I Understand and agree</strong></a>

...

"READ THIS" does not display, but then I believe it is illegal, being within 
the OL block but outside of an LI tag.

However, the "I Understand and agree" link does not display either.

Comment 1

18 years ago
I see all 5 rules on Linux 2000-08-15-05.
(Reporter)

Comment 2

18 years ago
The rules aren't the problem (for me) -- I see them all, too.  Right below 
them, do you see an "I Understand and agree" link, or does it skip right to 
the "Note:" section.  Perhaps this is a platform-specific issue.

Comment 3

18 years ago
I see the bug with 2000081415 on NT.

validator.w3.org squawks about the "READ THIS" bit being inside the list w/o
being a list item, but doesn't mention the "I understand and agree" link as
being problematic.

Comment 4

18 years ago
1. Document forces strict parser mode - document type is HTML 4.0 Strict
2.
Line 74, column 7: <strong>READ THIS</strong>
                          ^
Error: start tag for "LI" omitted, but its declaration does not permit this

this means this should not be rendered. mozilla does it right.
marking worksformed, if you wish that READ THIS is displayed, remove doctype
at the beginning of the document.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

18 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 5

18 years ago
"Line 74, column 7: <strong>READ THIS</strong>
                          ^
Error: start tag for "LI" omitted, but its declaration does not permit this"

As I mentioned, I am aware of that issue, and didn't expect that text to be 
displayed.  It is the link below that concerns me, particularly given that even 
other pickier browsers like Opera and Amaya *do* display the link.  

I *know* all 5 rules display, and I *know* why READ THIS does not.  No one has 
addressed the missing link, which is the part that concerns me.
This is bad user-experince resulting from the Strict DTD.
Assignee: clayton → rickg
Status: UNCONFIRMED → NEW
Component: Layout → Parser
Ever confirmed: true
QA Contact: petersen → janc
Whiteboard: [Strict DTD Invalid Page]

Comment 7

18 years ago
Are we saying, then, that the absence of the "I understand and agree" link is
due to the Strict DTD?
(Assignee)

Comment 8

18 years ago
wont fix; pulling strictDTD support.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WONTFIX

Comment 9

17 years ago
updated qa contact.
QA Contact: janc → bsharma

Updated

17 years ago
QA Contact: bsharma → moied
You need to log in before you can comment on or make changes to this bug.