Copy and paste don't work at all

RESOLVED WORKSFORME

Status

()

Core
Widget: Win32
--
major
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: alzayani, Unassigned)

Tracking

Trunk
Future
x86_64
Windows 7
Points:
---
Bug Flags:
wanted1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [win7])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)

I am using Windows 7 build 7100 (RC) X64, and Firefox 3.5 beta 4 English



Reproducible: Always

Steps to Reproduce:
1. Open Firefox 3.5 beta 4 under Windows 7 7100 X64
2. Go to any page and copy any text
3. The copy text is not in the clip board and if you can't paste the text you copy
Actual Results:  
Text is not copied to the clipboard

Expected Results:  
Text should be copied to the clipboard and you should be able to paste it

I try this in 3 PC and a laptop in both normal and safe mode, still the same bug
(Reporter)

Updated

9 years ago
Flags: blocking-firefox3.5?
Version: unspecified → 3.5 Branch
Not blocking since we don't officially support Windows 7 nor 64-bit, but adding some people who are looking into windows 7-y stuff.
Flags: blocking-firefox3.5? → blocking-firefox3.5-
Whiteboard: [win7]
If not for 3.5.0, this will need to block shortly after for a point release.
Component: General → Widget: Win32
Flags: blocking-firefox3.5-
Product: Firefox → Core
QA Contact: general → win32
Version: 3.5 Branch → Trunk
Flags: blocking1.9.1?
Definitely wanted, but until we confirm I don't think we can block.

Jim: if you get a second, can you take a peek? Copy and Paste works for me in Windows 7 32bit, fwiw.
Flags: wanted1.9.1+
Flags: blocking1.9.1?
Flags: blocking1.9.1-

Comment 4

9 years ago
(In reply to comment #3)
> Definitely wanted, but until we confirm I don't think we can block.
> 
> Jim: if you get a second, can you take a peek? Copy and Paste works for me in
> Windows 7 32bit, fwiw.

Working here for me as well in 32-bit. I need to update my win7, so I can do a two step where I first install 64-bit to test this. I need to finish up some work on panning feedback first though, so I'll try to confirm a little later this week.
I don't have the RC, but copying works for me on 64 bit Windows 7 Beta with 3.5b4 and 3.0
Flags: blocking1.9.1- → blocking1.9.1?
For now this seems to be "works for me", please re-open if we can get a confirmation.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Flags: blocking1.9.1?
Resolution: --- → WORKSFORME
Target Milestone: --- → Future
This bug is from a long time now. I'm using XP and got this problem since 3.0 was introduced. This is not only on Windows 7. Try to find "copy paste" bugs and count how many of them are registered in bugzilla. This is still not fixed.
Same here on Radoslaw's comment

I can't right click a single thing, copy, paste, etc.  

XP, dunno what brand of ff, and i couldnt even tell you my win.

But I NEED MY COPY AND PASTE. Im tired of working in IE
Go in to about:config, put in "conosle" and then flip javascript.options.showInConsole to true (double click).

Then open up the error console (Tools -> Error Console), clear everything out if there's leftover junk there, then try to copy/paste/whatever... does anything show up?

Also, how are you copying?  Does selecting something and going to the Edit menu and selecting Copy work, while using the right-click menu doesn't work?  Does hitting Control-C work?  Does selecting copy from the right-click context menu work?  Or does nothing work?
Nothing works. I can't right click anything. i even cleared out my virus bay in avg and spybot. I still got nothing. I tried what you stated and i can't get it.
By "can't get it", you mean nothing shows up in the error console?
No. Ok here is what i did

I ran spybot and avg scans last night, did a right click clean up because i had a bug. Restarted, loaded ff and tried to right click. Nothing happened. no bar to display copy, paste, delete, etc.

I did the error console thing, cleared cookies, and tried right click before restarting ff and nothing. No right click, nothing. Maybe I can like, undo the updates? it happened two updates ago. Is that possible? Or am i missing something?
Can you right click in other applications? (I know, sounds like a silly question but just trying to narrow down possibilities). Do the keyboard shortcuts work? Can you select text?

Can you tell us your update history? From the menu, Tools -> Options, click "Advanced", click the 'Update' tab and click the "Show Update History" button.

Also, have you installed other software or is this issue happening on a clean install of Windows 7?
it was a security update. installed 8-11  FF - 3.5.2


no. i havent installed anything. I dont have add ons or anything. Ive been working in ie and his has no security like ff so yeah im a little peeved. lol. I hope the above info helps.
Problem fixed. It was the yahoo toolbar that needed to be disabled. Thank you to live support and those who tried to help. At least now if anyone has a problem they can disable yahoo toolbar in the add ons.

Comment 16

8 years ago
I have a similar problem but do not use any add-in toolbar, Yahoo or otherwise.

From the message/headers list, if I right click a message and "Copy to clipboard > Message", _sometimes_ but only occasionally nothing is sent to the clipboard and Thunderbird crashes. Usually it is with a questionable email that I cannot determine whether it is spam or legitimate, so I "copy to clipboard > Headers" then "copy to clipboard > message" to investigate by "safely" pasting into a text editor.

I would use the built-in crash reporting, but it cannot connect. I do not use a proxy, just a 1:1 NAT and SonicWall firewall.

Can this be considered a similar issue or should I submit a new bug report for the T-bird crash on "Copy to clipboard > Message"?
You need to log in before you can comment on or make changes to this bug.