Feed with many images in Google Reader shows only some of images

RESOLVED WORKSFORME

Status

()

Firefox
General
--
minor
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Edgaras, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; lt; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; lt; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

"Captured" (http://blogs.denverpost.com/captured/) is image blog and gives full content feeds containing many images.
I've subscribed it in Google Reader. However Firefox doesn't loads images so I have to open original page to see all images.

It looks like some memory or total height limit, because images are cut in middle of them and then it is only white area.

Reproducible: Always

Steps to Reproduce:
1. Subscribe feed with much images in Google Reader.
2. Load that feed.

Actual Results:  
Not all images are shown/loaded. If I move mouse over not loaded image I get hand icon.
When tooltip shows and then disappears, it leaves black blocks.

If I select to show all items, then each item shows some images and then in the end of item again do not shows some images.

If I zoom out much then all images are shown.

Workaround: To see all images open original page - all images are loaded.

Expected Results:  
Firefox should load all images.

I've tested this in clean Firefox profile - same result.
Also tested in Opera 9.64, Google Chrome 2.0 and Safari 4 - loads all images.
(Reporter)

Comment 1

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090507 Minefield/3.6a1pre (.NET CLR 3.5.30729)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

I've tested this again on Win7 RC on VMWare: Firefox/Minefield shows all images, but I can't select text below same line where images stops showing on WinXP, so this depends on OS or system resources. However on WinXP I can select and copy text (mouse changes to text selector cursor when it is over so I can select it by blind method).
Also right clicking in that area in Win7 shows context menu at top of screen, while on WinXP it shows normally.
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Comment 3

8 years ago
I've tested that with testcase of overflow: auto and height > 32768px.
I've tested it with Firefox 3.6.10 and 4.0b7, and now everything is OK.
I also redownloaded 3.0.10 to test it also, and it cropped image at ~32768px.

So this was fixed sometime, bug is resolved, fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.