crossed-out Duke icon appears in Windows task bar

VERIFIED FIXED

Status

Core Graveyard
Java: OJI
P3
normal
VERIFIED FIXED
18 years ago
7 years ago

People

(Reporter: ekrock's old account (dead), Assigned: stanley.ho)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using Commercial 2000081508 on WinNT 4.0 SP4.

On startup of N6, in the Windows task bar on the right-hand side (just to the
left of the clock), a Duke character appears with a red cross through it.
(Suggesting some kind of a problem with Java?)

When I click the Duke, the Java Console appears with this text:

 Java(TM) Plug-in: Version 1.3.0_oji_pr2_07262000
 Using JRE version 1.3.0 Java HotSpot(TM) Client VM
 ----------------------------------------------------
 c  clear console window
 f  finalize objects on finalization queue
 g  garbage collect
 h  display this help message
 m  print memory usage
 q  quit
 t  dump thread list
 ------------------------------------------

... and the Duke stops being crossed out. But as soon as I close the Java
Console window (whether or not I first Clear it), the Duke is once again crossed
out.

Expected: Duke shouldn't be crossed out unless there's really a problem

Actual: Duke is crossed out anytime the Java Console's not open

Comment 1

18 years ago
I saw this too on today's build. Right clicking on the duke enables the "Show 
Console" option which when selected removes the cross. Again, right clicking now 
enables" Hide Console" and selecting it crosses out the duke again.

Comment 2

18 years ago
Re-assigning to Stanley Ho.  Perhaps he can enlighten us, if not fix it 
(assuming this really is a bug and not intended behavior!).
Assignee: drapeau → stanley.ho
(Assignee)

Comment 3

18 years ago
George, this is the intended behavior. A cross Duke represents a closed 
console. We can definitely change it if people find it confusing.
Status: NEW → ASSIGNED
(Assignee)

Comment 4

18 years ago
To avoid confusion, we have changed the duke icon. When the console is closed, 
the duke icon will hand down instead of hand up.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 5

18 years ago
are we(netscape folks) scheduled  to receive another version of the java plugin 
soon? 
(Assignee)

Comment 6

18 years ago
We are closing in code freeze for PR3, and Geroge will provide another drop next 
week.

Comment 7

18 years ago
verified this is working as per stanley's comment (build:200092808 branch 
m18).marking VERIFIED.
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.